Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an HP Mini netbook and a Belkin wifi router, and both worked perfectly fine until recently. I acquired an HTC Flyer tablet, which refused to recognize my wifi router but was able to recognize all other nearby routers. After looking around on the net, I found a solution - to change the router's wifi channel to 10 or 11 (it worked with 11). Earlier the router was set to auto-select channels, and this worked fine with all other wifi equipment at home (HP Mini, Samsung Galaxy S2, and a Dell Studio laptop). Now - my Dell gets very poor connectivity, my Galaxy S2 sometimes disconnects, and my HP Mini disconnects every 5 seconds and cannot connect to the internet at all.

And the cause of the disruption, the HTC Flyer, works happily. How do I get all my devices to play nice? Primarily I'm looking at a solution for the HP Mini (running Windows 7 starter), since it cannot use the net at all. I went to the wifi adapter settings (Broadcom chipset), but there's no explanation given for any of them so I don't know if or what I should change here.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

If you have a European (ETSI) model of Wi-Fi AP that supports channels 1-13, and some US (FCC) Wi-Fi client devices that only support channels 1-11, I could understand manually setting your AP to any channel from 1 to 11 (but not 12 or 13) so your FCC devices would be sure to join.

But if you have a Wi-Fi client device whose RF design is so crappy that it really only works well at one end of the band (channels 10 and 11), then I'd throw out that POS and buy something that doesn't suck.

Try manually setting your AP to channel 1, then seeing how all your devices do. Then try manually setting it to channel 6 and see how all your devices do. Hopefully between channels 1, 6, and 11, you'll find a channel that all your devices can do fine on.

Also, to be a good neighbor, if your Belkin Wi-Fi router supports 802.11n, make sure you're not using "wide" (40MHz, HT40) channels in the 2.4GHz band. Use only traditional 20MHz (HT20) channels in 2.4GHz, to leave room for Bluetooth and your neighbors' networks and the like.

share|improve this answer
    
I think I'll try checking the channels when I get home from work. The channel band setting is set to use both 20 and 40 MHz..will that cause problems? –  Rex Feb 7 '12 at 10:39
    
@Rex Yes, the 802.11n spec does not provide for a 40MHz-only mode, so when I said 40, I really meant 20/40. 20MHz-only is the better mode for 2.4GHz gear to use, to be a good neighbor. –  Spiff Feb 7 '12 at 10:56
    
Channel 1 worked! –  Rex Feb 7 '12 at 18:01
    
@Rex Glad to hear it. Thanks for the followup. It's always gratifying to know that a suggestion was helpful. –  Spiff Feb 9 '12 at 7:55
add comment

When you router is set to auto select a channel it will switch channels if it detects interference, e.g a neighbour with a router on the same channel, interference from a microwave / other electrical gear. Now you have it fixed on one channel dropouts are to be expected as the router can no longer change channel to avoid the interference so instead the signal gets so bad / corrupted from interference it just drops the connection now instead.

Have you tried upgrading your routers firmware ?, there may be a bug with your router that has now been fixed in a firmware update.

share|improve this answer
    
Router's already on the latest firmware - last update it got was in July 2010. –  Rex Feb 7 '12 at 10:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.