Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a desktop computer with PS/2 (!) keyboard and mouse, running Fedora 16, just recently installed. It goes to sleep OK, but moving the mouse wakes it up. I'd like moving the mouse not to wake it up--typing on the keyboard would be fine.

I found an article online ( http://blob.inf.ed.ac.uk/chris/2011/03/04/linux-sleep-how-to-wake-with-a-key-press-or-mouse-click/ ) that told me to look in /proc/acpi/wakeup, so I did:

Device  S-state   Status   Sysfs node
PS2K      S3    *enabled   pnp:00:03
PS2M      S3    *disabled  pnp:00:04
BR20      S4    *disabled  pci:0000:00:1e.0
EUSB      S3    *enabled   pci:0000:00:1d.0
USBE      S3    *enabled   pci:0000:00:1a.0
PEX0      S4    *disabled  pci:0000:00:1c.0
PEX1      S4    *disabled  
PEX2      S4    *disabled  
PEX3      S4    *disabled  
PEX4      S4    *disabled  pci:0000:00:1c.4
PEX5      S4    *disabled  
PEX6      S4    *disabled  pci:0000:00:1c.6
PEX7      S4    *disabled  pci:0000:00:1c.7
GBE       S4    *enabled   pci:0000:00:19.0
P0P1      S4    *disabled  
P0P2      S4    *disabled  
P0P3      S4    *disabled  
P0P4      S4    *disabled  
GBE1      S4    *disabled  
PWRB      S3    *enabled   

To me, it looks like the mouse (PS2M I assume) should not wake up the computer. Yet it does.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Normally, you can also set this in the BIOS which I think is alot easier than hacking your fedora.

share|improve this answer
    
I'm quite sure my BIOS has no such option, unless it's called something non-obvious. It's a stock HP desktop, so the BIOS is not exactly a tweaker's paradise. –  John Zwinck Feb 7 '12 at 10:50
    
@JohnZwinck Well ok, if it is a OEM machine, your possibilities might indeed be limited, however strange names are not uncommen and it is actually a pretty standard BIOS option. I think a second look would be worth a try. –  bamboon Feb 7 '12 at 10:53
    
I've accepted your answer not because it worked for me, but because it's the only one I got and seems like it might work for some people. For me, I just stopped using sleep, and let the thing waste power. Oh well. –  John Zwinck Sep 20 '12 at 7:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.