Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How to override wincmd.ini location after Total Commander was installed? I can't seem to find a menu item for this setting. Where is this setting stored? Operating system is Windows XP or Windows 7 32bit.

share|improve this question
    
What OS are you on? –  Raystafarian Feb 7 '12 at 12:58
    
Updated issue description. –  truthseeker Feb 7 '12 at 13:17

3 Answers 3

up vote 5 down vote accepted

First, edit wincmd.ini, look for UseIniInProgramDir= and set it to 7.

UseIniInProgramDir=Flags sum This variable will only be read if the wincmd.ini is located in the same dir as the program. It is the sum of the following values : 0: Disabled 1: Use wincmd.ini in the program-dir. if no other location is set via the registry or parameters 2: Use wcx_ftp.ini in the program-dir. if no other location is set via the registry or parameters 4: Override the registry settings (but not the command line parameters)

Then, edit the shortcut to Total Commander so that it looks like this:

TC_path\TOTALCMD.EXE /i=config_path/wincmd.ini

Where TC_path is the path to totalcmd.exe and config_path is the desired path to wincmd.ini

share|improve this answer
    
I'm using the v8.01, there is no setting like UseIniInProgramDir. Did it change? –  B. Roland Feb 17 '13 at 13:25
    
Just try creating the entry, it should work. –  molgar Feb 17 '13 at 22:24
    
wincmd.ini is not user-writable on my workplace computer, that is the very reason I want to override it with my own :( is it possible? or do I need to install a portable version? –  törzsmókus May 28 '13 at 15:36

If you simply want to move the ini-file; You can use the tool inireloc from the Total Commander addons page at: http://www.ghisler.com or check: http://ghisler.ch/board/viewtopic.php?p=135417

share|improve this answer

I've needed this too, But for 2 files: wincmd.ini and wcx_ftp.ini.

totalcmd.exe /I=%pdrive%/totalcmd/MyCMDs.ini /F=%pdrive%/totalcmd/MyFTP.ini

I made a copy of the original files and renamed them for personal reference. You might have to change directories: Mine is c:\totalcmd\.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.