Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having some problems with my Ubuntu 11.10 installation on a Toshiba A300-16l laptop, of which the primary problem appears to be allowing permissions escalation.

I want to backup my home directory before reinstalling Ubuntu, but I can't seem to get my USB stick mounted. Each time I plug it in, I get the following error:

Unable to mount USB DISK
Not Authorized

Unable to mount USB DISK

The device shows up with lsusb as "Kingston Techonlogy Company Inc.", and dmesg | tail gives:

 sdb: sdb1
sd 8:0:0:0: [sdb] No Caching mode page present
sd 8:0:0:0: [sdb] Assuming drive cache: write through
sd 8:0:0:0: [sdb] Attached SCSI removable disk

Attempting to mount it manually gives:

$ sudo mkdir /mnt/sdb
$ sudo mount -t vfat /dev/sdb /mnt/sdb
mount: wrong fs type, bad option, bad superblock on /dev/sdb,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

Finally, dmesg | tail gives:

FAT-fs (sdb): invalid media value (0xb9)
FAT-fs (sdb): Can't find a valid FAT filesystem

Is there any hope of getting this working?

share|improve this question
Is there any other machine that does recognize the USB stick, and if so, what filesystem is used on the stick? – MSalters Feb 7 '12 at 14:37
Windows reports it as a 3.7 GB FAT32 disk and displays its contents. – Paul Lammertsma Feb 7 '12 at 14:38
up vote 4 down vote accepted

The dmesg information is reasonable; the media value for FAT32 should be 0x0b.

You might want to try /dev/sdb1. USB mass storage is used for both harddisks and flash. Since harddisks traditionally had partitions, and flash didn't, there's no sure way to predict if a given USB device will have a partition table.

share|improve this answer
Just to add, you can use file -s to get some info about the device: sudo file -s /dev/sdb and same for sdb1 if you have it. – FatalError Feb 7 '12 at 15:06
Instantly worked. I should have tried the other sdb* devices, but for some reason was confused by the error with sdb. – Paul Lammertsma Feb 7 '12 at 15:07
@FatalError: Sure enough, Ubuntu lists it with "partition 1". It then makes sense that /dev/ contains precisely /dev/sdb and /dev/sdb1. Thanks for the tip! – Paul Lammertsma Feb 7 '12 at 15:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .