Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using OS X Snow Leopard. I have a web application hosted locally in the web server folder with _www user and _www group.

I'm unable to edit those files with my local user, who is part of the group admin.

share|improve this question
    
This one sounds familiar: Unable to edit files on Macbook pro. Permission denied –  slhck Feb 7 '12 at 15:29
    
So is the one above your question? –  slhck Feb 7 '12 at 15:50
    
no I commented on it because it was very similar to mine. –  jini Feb 7 '12 at 16:03
add comment

1 Answer

up vote 5 down vote accepted

The best option is to add your local user to the _www group ; that's what groups are there for. Being administrator doesn't mean you own other user's files. You could of course override this using sudo, but this is bad.

Bottom line: add your local user to the _www group and make the files in the web server folder group-writeable ( chmod -R g+w /path/to/we/server/folder/ )

See this answer on how to add your local user to the _www group.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.