Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I noticed that mplayer moves mouse cursor every 10 seconds:

ltrace -e '!read,select,vsnprintf,ioctl,XSync,XShmPutImage,malloc,memcpy,free,XNextEvent,XPending,sws_scale_ordered,pp_postprocess,avcodec_decode_video,strcmp,gettimeofday,nanosleep' -p  `pidof mplayer`
XWarpPointer(0x8ce9480, 0x1800002, 0, 0, 0)                                  = 1
XWarpPointer(0x8ce9480, 0x1800002, 0, 0, 0)                                  = 1

Probably it is to trick possible screensaver. There are no -stop-xscreensaver or mouse-related options speicfied.

How to turn off such behaviour?

share|improve this question
Which version of mplayer? – Dan D. Feb 7 '12 at 19:49
MPlayer 1.0rc3-4.4.4 (C) 2000-2009 MPlayer Team, Debian Squeeze default. – Vi. Feb 7 '12 at 20:20

You must log in to answer this question.

Browse other questions tagged .