Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My 64bit PC running Windows 7 was hanging on AVGIDSEH.SYS at boot. After googling this issue (which appears common) I renamed the AVG folder in Program Files and removed all avg*.sys files from system32 as per the advice of several forums.

At this point Windows began hanging on CLASSPNP.SYS during boot. Throughout all of this I was able to boot Ubuntu from a flash drive and access the file system.

From the recovery console I let Windows Startup Repair run to see if it would actually get the system to boot before I tried the command prompt to run chkdsk and sfc etc.

Startup Repair seemed to work, it took slightly over an hour (as the prompt suggested it would) but restarted to A disk error has occured, press CTL+ALT+DEL to restart.

The hard-drive made a funny noise, so I ran SMART tests (short and extended). Both passed within a minute.

I accessed the recovery console command prompt and tried to navigate to the C: drive, and received a message saying the drive was corrupt and unmountable.

Booted Ubuntu again and all of the user files, program files, and many other executables and .dlls are missing although the directory structure remains and all I get when I try to boot is A disk error has occured.

Did start-up repair really eat my files or just lose them? Should I just format and reinstall at this point? Could the drive be toast even though it passed SMART and I can still see the remaining files from Ubuntu?

share|improve this question
    
I suggest running SpinRite on the drive. If any program can attempt to resolve your disk problems, SpinRite might be able to, does a bunch of stuff that helps in a case like this. –  Ramhound Feb 8 '12 at 17:19
add comment

2 Answers

up vote 1 down vote accepted

Run chkdsk /r on the hard drive from command prompt, see if it will run, if it does it will take a long time depending on the size of the C partition, be patient and do not interrupt it. I think you have more serious hard drive issues, as SMART tests do not always reveal impending hard drive failure. best to run the hard drive manufacturers disk diagnostics on the drive

share|improve this answer
    
I ran chkdsk, it ran for a while then quit and returned the error 'Couldn't open volume for direct access.' I think I'm done trying with this one, thank you for the advice though –  EBo Feb 9 '12 at 6:05
    
I am starting to see some motherboard problems in notebooks where it is the motherboard sata controller failing but making it look like a hard drive, I would remove it and test on another PC to be sure if it is in a notebook . –  Moab Feb 9 '12 at 6:34
    
Nah it's a desktop, but I'll give it a shot this evening when I've got it out anyways –  EBo Feb 9 '12 at 20:15
add comment

The odds that two files to do with critical system boot routine should stop working are quite small but it is suspicious that this started with an error to do with antivirus. It's possible for malware to cause this kind of issue with Windows if it is advanced enough (TDL3 perhaps?)

I suggest running chkdsk /r to repair bad sectors on your hard drive if there are any, or if you aren't worried about losing any data, simply perform a full format of your HDD and reinstall Windows.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.