Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Ubuntu Server on an old Compaq Desktop machine, for a development server. (Don't have the model number handy, can verify later).

But when it's on, it seems the fans run loud constantly, and never go quiet or adjust, as I have noticed it would do when Windows was installed.

Where should I begin looking to troubleshoot/solve this problem? (Aside from SuperUser, of course!)

share|improve this question

4 Answers 4

up vote 2 down vote accepted

I would look into making sure ACPI and APIC and everything else is enabled for the motherboard, and also in Ubuntu. The motherboard may only have drivers that are windows-compatible because of some quirk in how they are made.

You don't mention how old the system is. In my experience only the last few years of Compaqs have played really nicely with Linux.

share|improve this answer

Unfortunately, HP/Compaq desktops may not have complete driver support. I know that the HP servers have extremely good linux driver and utility support. It definitely sounds like a mainboard driver issue.

This question may belong on serverfault.com

share|improve this answer

manually change fan speed in Ubuntu (many motherboards):

as root:

echo 1 > /sys/class/hwmon/hwmon0/device/pwm1_enable

echo 60 > /sys/class/hwmon/hwmon0/device/pwm1

share|improve this answer

I had a similar problem...but on a NEW small form factor Dell. After a lot of searching I found the answer in the ubuntu forums. It seems that there is something running in the background which is continually caching pictures/videos etc. My machine it turned out didn't get enough air circulation through it, so that caused the fans to kick into overdrive.

There was/is a way to disable this program running, but I can't remember what it is or how to disable it, but I will advise a search on the ubuntu forums.

I wouldn't really advise ubuntu fo old machines, I think they are moving in the opposite direction. Maybe try another distro?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.