Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having connection issues with my router (Linksys WRT610N) at home. There are a number of things that are happening (may be more, this is just what I've mainly noticed)...

1) Using my laptop (Macbook Pro OSX Lion), I am unable to complete any operations with my external FTP server, hosted with FatCow. I can connect to it, navigate through all the files, but when I try to edit/delete/add a file the operation times out. EVERY time. I've used two other Wifi connection on my laptop and neither have this issue.

2) I am unable to upload photos/videos to Facebook or Twitter using my phone (Samsung Galaxy S2) or my tablet (HP Touchpad - CM9). Neither am I able to upload files to Dropbox via either of the devices. Same thing happens in all situations; the upload will begin and it will just hang on 0% forever. After about 10 mins I am always forced to disconnect the Wifi to stop the action.

3) My laptop is having slow internet speed, even though we are on 20mb broadband. Speedtests say I'm getting a good connection and my Ping is good, but when using streaming services like Spotify, it takes forever to load a page and frequently stops to buffer whilst playing a song.

Don't know if it's worth mentioning but I have no issues with my XBox (Ethernet), AppleTV (Wifi) or my girlfrield's phone (Nokia Lumia 800 - WP7.5) on the network.

I'd really appreciate any help. This is driving me insane and is really affecting both my working and leisure use of the internet.

share|improve this question
    
Are all devices connecting to the Internet through the same equipment? Or are the working devices connecting differently than the non-working devices? –  goblinbox Feb 9 '12 at 20:09
    
Issue 1: FTP or SFTP? –  UtahJarhead Dec 27 '13 at 15:44

3 Answers 3

Do the MacBook Pro's problems still happen even when it's plugged into a LAN Ethernet port of your WRT610N (and the MBP has Wi-Fi turned off)? I ask because this sounds a bit like a Path MTU Discovery black hole problem, but that probably wouldn't be Wi-Fi-specific. The data point of the Xbox 360 on Ethernet not having a problem is not quite enough to convince me that it's not a Path MTU Discovery problem, because maybe the Xbox 360 is extra conservative with MTUs.

If the problem still happens when the MacBook Pro is on Ethernet (with Wi-Fi off), then keep it connected to Ethernet for now and try this experiment: Go to System Preferences > Network > Ethernet > Advanced... > Hardware > Configure: Manually > MTU: Custom, set it down to 1300 and see if the problem goes away. If it does, then try higher values until you find the highest value that doesn't show the problem.

MTU problems on home broadband are most common on DSL services that use PPPoE. PPPoE has an MTU limit of 1492 instead of the Ethernet value of 1500, and some ISPs may have an even lower MTU. Home gateway routers often employ a trick called "[TCP] MSS Clamping" to make sure your traffic fits inside the lower MTU, but maybe some don't do that, or maybe your ISP's equipment is screwed up and doesn't negotiate a proper PPP MRU during PPPoE negotiation.

share|improve this answer
    
No issues with XBox, Apple TV or Nokia phone. Very unlikely MTU then. –  Matt H Feb 9 '12 at 18:46
    
@MattH I find it curious that you would leave that comment and (I'm guessing it was you) downvote this Answer for it, and then 5 minutes later decide it's likely enough to be worth addressing in an update to your own Answer. Do you feel it's enough of a possibility to be worth bringing up, or not? –  Spiff Feb 9 '12 at 19:18
    
Grow up spiff. I'm just trying to help the guy out. I added mtu stuff to my answer to "rule it out" but I think it's very unlikely. –  Matt H Feb 9 '12 at 20:56

Some things to try:

Step 1: Log into your router and temporarily disable N networking. i.e. force it to use G only. Restart and see what happens. Is it having issues still?

Step 2: Download all the updates for Mac. Change router back to how it was originally. Retry to see if the dropouts are still occurring.

Step 3: Go back to wifi page and turn off all advanced features like "afterburner" and "frame aggregation" if enabled. Try them.

Step 4: Have you got the airport extreme enabler installed? It sounds like it may not be needed. But it's very unclear. http://store.apple.com/us/product/D4141ZM/A

It's misleading but it looks like it is a firmware update to the wireless card in some mac models and enables N networking in the wireless cards. For only $1.99 it's worth trying.

MTU??? If it is MTU, as suggested by another answer. You can work out if that is a problem right now by doing the following.

First, disable the airport on your macbook pro. Plug the macbook with a LAN cable directly into the router. Does the problem still exist? If not, we've likely narrowed it to a wifi problem. However, it it still does it then lets try the MTU test.

If it does lets try and determine if it truly is an MTU problem. Although, you've said it's only the macbook pro that is doing this which would suggest this is NOT the problem. However, to be absolutely certain, follow these steps.

Open up a shell or terminal.

ping www.google.com

You should see some replies (if not try a different hostname, at my end it is replying).

Next type

ping -s 1500 www.google.com

Do you get a reply? If not start decreasing the size. After 1500 try 1472 and keep going a little lower until you get a reply. Eventually you should see a reply.

It it happens that 1500 doesn't work and 1472 does, then it's highly likely the old pppoe issue mentioned. There may be a setting on the router that allows you to set the MTU. This should be done automatically by any reasonable router, even most cheap ones these days do it. If not, then you can set the MTU on your computer in the network settings of MacOSX.

See: http://hints.macworld.com/article.php?story=20020712014842725

share|improve this answer
    
Two comments: (1) 802.11n was ratified and became a full-blown standard in 2007, just 6 months after the first vendors shipped draft-N gear. (2) The AirPort Extreme 802.11n enabler was only necessary for a few models of Macs that secretly shipped with 802.11n-capable hardware for a few months in 2007, and it was only necessary if you wanted to use N while continuing to run Tiger (Mac OS X v10.4). Leopard (Mac OS X v10.5) and later "included the enabler" so to speak -- they included drivers that enabled the 802.11n capabilities of the hardware. –  Spiff Feb 9 '12 at 7:05
    
@Spiff, He didn't say how old his mac was, although it is running Lion. And FYI, Apple do not even say exactly which versions that the airport extreme enabler effects. That's why I suggested looking at it. However, it's 4th on my list of things to try. –  Matt H Feb 9 '12 at 18:35

I am not sure if it's the issue: if the security mode is wpa2 personal, the wpa algorithms has to be AES, or It won't work on OSX 10.6.8 and above.

For the ftp thing, I would suggest you use sftp which always has less problem.

share|improve this answer
    
Thanks for the reply. Yes, the security is WPA2 Personal. At the moment it's set to 'WPA-TKIP or WPA2-AES'. I've tried SFTP and still have the same issue. –  Kelvin Farrell Feb 8 '12 at 1:05
    
change it to AES only. My iMac had the same problem before. –  Fivesheep Feb 8 '12 at 1:09
    
Done! Where you having similar issues that I have mentioned? –  Kelvin Farrell Feb 8 '12 at 1:17
    
Doesn't seem to have solved the problem. Still having the above issues. Thanks though. –  Kelvin Farrell Feb 8 '12 at 1:29
    
There's no such thing as WPA2 without AES. The Wi-Fi Alliance is the body that came up with WPA2, and they defined it to always require AES. –  Spiff Feb 9 '12 at 0:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.