Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Excel 2007, when User A creates a new workbook, there is only 1 worksheet for the book. When user B creates a new workbook, there is the standard 3 worksheets for the book. How do I get this back to default for User A?

The workbook being opened has more than 50 worksheets that have been in the file for the last year. When User B opens the file, all 50 or more sheets are accessible. This happens with both files saved as 2003 files because the workbook has VBA macros in it and if I open new xlsx files that are in Excel 2007 format.

Cancel the question. This was apparently a cockpit error. the workbook was sized very large when a space delimited (.prn) version of one worksheet was made. I would swear I checked this before I asked the question, but I just reduced the workbook size again and the problem went away. It is interesting that the problem migrated to all excel files for user A.

share|improve this question
    
What? You have one user that opens workbooks with 3 sheets and another user that opens workbooks with 1 sheet? – Raystafarian Feb 8 '12 at 1:35
    
NO. the workbook already exists with 50 or more worksheets in it all with data in them. You oversimplifed the question. – user117308 Feb 8 '12 at 21:50
    
@Raystafarian Please be more subtle with those edits. You removed possibly important information and left nothing of the original question. Just rewrite a post to fix grammar and correct obvious mistakes, and respect the original author. Thank you! – slhck Feb 8 '12 at 22:28

That's a per-user setting, with the default 3. To change it in Excel 2007, go to Microsoft excel button (multi colored top left icon, aka "pearl") -> excel options button (bottom right) -> popular tab. in the "when creating new workbooks" section change include this many sheets to your desired number of sheets.

share|improve this answer

And in Excel 2010 change it as follows:

Click on green File tab then Options. In the General section find When creating new workbooks. Set Include this many sheets to the number of worksheets you want.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .