Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Word 2007 under Windows XP.

Often, a section heading (styles like "Heading 2", Heading 3") happen to be the last line on a page. This looks very ugly and destroys the logical flow of a document.

Can I fix this somehow, preferrably not manually?

Manually inserting a page break right before the offending section heading is not a solution, because I might enter text later somewhere upstream in the document, and then there would be a superfluous page break.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

If you're using the built-in heading styles, you shouldn't have this problem because they are set to Keep with next by default. If that's failing or you're using a custom style, here're the steps to enable the proper behavior:

  1. Select the paragraph you need by double-clicking on the left margin next to it (the cursor changes to a mirror-reflection of itself when moved into the margin).
  2. Open the paragraph option dialog by clicking the button in the lower-right of the paragraph section on Home tab of the Ribbon:
    enter image description here
  3. In the Line and Page Breaks tab of the dialog, make sure that Keep with next is checked:
    enter image description here
  4. Click OK.
share|improve this answer
1  
Thank you works great. I am using the built-in heading styles, and keep with next is not enabled by default. Can I somehow enable this for all headings? Because it is very tedious to do every time this problem pops up. –  gojira May 8 '13 at 3:57

To apply this automatically to all headings within the document you have to edit the styles. (This was done with Word 2010 on Windows 7)

  1. On the Home tab click the button in the lower-right of the Styles section: enter image description here
  2. In the Styles window that appears click on the "Manage Styles" button: enter image description here
  3. In the Manage Styles window that appears, click on Heading 1 in the "Select a style to edit" list and then click on the "Modify..." button: enter image description here
  4. Once the Modify Style window appears, click on the "Format" button near the bottom of the window and choose "Paragragh...". Then choose the "Keep with next" option as described in dnbrv's answer.

This should update the setting for all headings that are either Heading 1 or based on Heading 1.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.