Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an a Symbol barcode scanner model LS2208 that I'm trying to use on a Windows XP machine. The scanner uses RS-232 for its connection.

The problem I'm having with the scanner is that it can never be found by the software application whether or not that application is a third party application or the software that came with the scanner (123scan2).

After much tinkering I've figured out that scanner is being claimed by the Windows Print Spooler service when the system boots up. If I disable the Spooler Service or set the Service to manual, the scanner will always be found and works properly. Once the service is however, the scanner is reclaimed and I lose all access.

Is there a way where I can limit the print spooler service to what ports it has access to? (I'm thinking that if I can tell print spooler to never claim the device on com 1 I should be ok) or Is there a better way to resolve this?

share|improve this question

migrated from serverfault.com Feb 8 '12 at 8:28

This question came from our site for professional system and network administrators.

2 Answers 2

up vote 1 down vote accepted
+50

You could maybe try to disable your printer(s), rather than the spooler, and see whether this also fixes the problem. If it does, then this may be a bug in the printer driver, so check if an update is available.

If the port in question has a name, you could check whether it is mentioned in Properties / Ports for all printer devices.

Search also for a driver update to the scanner device. It might misrepresent itself as a printer to the spooler.

share|improve this answer

The problem here was that the scanner was not being detected as some other program had a claim on the scanner. It turned out that other program was a PDF writer. These are normally installed as a printer and consume a port. This particular one claimed COM1, which was also used by the scanner. Changing the port of the PDF writer fixed the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.