Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Yesterday I put the computer to sleep. Something went wrong because it didn't go fully to sleep. So I restarted the pc and now it won't boot windows 7 anymore. It said : "Please insert valid boot device". I ran Windows 7 restore disc and tried restoring, first it said, mbr fixed. No result but now it said : "Operating system could not be loaded" I ran Windows 7 restore disc again and then it said something about a corrupt partition and that he fixed it. But got the same msg at restart about operating system not found. I ran Windows 7 restore disc again and used diskpart and watched the volumes. My SSD shows up as RAW filesystem... not as NTFS. The size of the disk seems correct. In the bios it also shows up as Healthy disk.

What could went wrong and could I recover data with testdisk? I assume something went wrong with the partition :(.

It's a Plextor SSD 256M2P SSD, only 3 months old.

Thx in advance

share|improve this question

migrated from serverfault.com Feb 8 '12 at 12:36

This question came from our site for professional system and network administrators.

    
It sounds like the drive's controller is starting to fail. –  Ramhound Feb 8 '12 at 17:15

2 Answers 2

You can boot off the Windows 7 disk, open the command prompt and running a check disk, i.e chkdsk /r C:, on the SSD. Please reference this site for step by step instructions: http://kb.wisc.edu/page.php?id=6565/. Also try running the Bootrec.exe utility from the command prompt while you're in the recovery environment too, http://support.microsoft.com/kb/927392/. I don't like the automated Windows 7 recovery tools because they never seem to work.

If all else fails, you should try attaching the SSD to another PC running Windows 7 and boot off of Parted Magic, http://partedmagic.com/doku.php/, and see if you can mount and extract the data.

After extracting the data to somewhere safe, reinstall Windows 7 on the SSD.

I've had a SSD completely die on me where I had "Please insert valid boot device". Attaching it to another computer or using the recovery environment didn't even recognize the drive.

share|improve this answer
    
I got lucky :), I used gparted live cd, then used testdisk , he saw the lost partitions and rewrote them. Then at reboot boot manager popped up :). Need to do a single repair with repair disc to fix the bootrec and WOOHA , there was windows booting again. From RAW to a booting windows, must donate to testdisk now :p –  LordrAider Feb 8 '12 at 18:07
    
@LordrAider So your problem is solved? –  Jochem Kuijpers Sep 29 '13 at 4:05
    
Yes :) , indeed it was –  LordrAider Oct 31 '13 at 14:01

It just happened something similar yesterday evening. To me BIOS recognize it but Windows is stuck during the startup, even safe mode, even recovery mode, even for a new installation just before it let you choose the drive where you want install it. The Operating System seems to see itself somehow but it does not recognize itself on a valid partition. It does not load all the drivers and stop to do everything as it is in waiting for an answer from the SSD.

But I found something on Internet today, I want try to run Diskpart tonight from the recovery disk in a prompt, which I can fortunately start and follow these instructions: http://blogs.bytecode.com.au/glen/2011/06/26/getting-windows-7-to-recognise-your-ocz-agility-ssd.html

My concern is that when I type "list disk" or "select disk x" it will stick there as well. But I hope it will help you. If this will work, then update any firmware if you didn't before.

share|improve this answer
    
I saw your comment to @bradbajuz later. Testdisk to me won't work, it is a standalone application to run when an Operating System works on another disk/cd. The fact that the SSD is not recognized it also lead to not start any new OS because OS wants load the disk, but the disk doesn't answer, and I am stuck again during the startup even with the new OS. Thanks God to you did work :) at least. –  Davide Steduto Feb 9 '12 at 10:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.