Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'd like to change the default behaviour of the location bar in firefox to search google unless I specifically enter a domain name.

For example typing in Superuser will take me to the Google SERP but typing in Superuser.com will take me to the website.

And I don't mean just changing the location bar from Google's 'feeling lucky' to a normal Google SERP

share|improve this question

4 Answers 4

up vote 9 down vote accepted

Something else to try is going to about:config and then changing the keyword.URL value.

By default it is set to this:
http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

Try changing it to this and see if it makes a difference:
http://www.google.com/search?q=

share|improve this answer
1  
+1 because you came up first :) –  Molly7244 Sep 10 '09 at 2:07
    
thanks quickcel –  cust0s Sep 10 '09 at 12:48
    
Molly ownage. =) –  Nathaniel Jan 29 '10 at 1:48

kinda like the omnibar? Single search/url bar, which searches to a search engine of your choice unless its an exact url.

share|improve this answer

For user who prefer to see a list of matching websites or search results instead of auto redirect to a web page when entering keywords in the Firefox’s link location bar, it’s possible to change the Firefox behavior by modifying its configuration using steps below.

Enter about:config into the address bar.

Locate keyword.url or type keyword.url into “Filter” text box to search for it.

Double click on the line of “keyword.url”.

By default, the string value for “keyword.url” is “about:neterror?e=query&u=”. To display search results instead, replace the string with one of the following search statements, depending on the search engine you prefer (e.g. Google: http://www.google.com/search?q=)

Click OK when done.

Source & more info

share|improve this answer

I have Firefox 3.5.2 and this is the default behavior. I haven't set up any features or settings. Maybe you have an old version, prior to them adding the 'smart bar' feature.. try updating here http://www.mozilla.com/en-US/firefox/personal.html

share|improve this answer
    
Interesting. I have that version and it takes me to Wikipedia via a Google search. It is definitely performing a Google "I'm Feeling Lucky" search. –  jasonh Sep 10 '09 at 1:35
1  
kpoehls is right, this is the default behaviour, maybe you have continiously updated from an older version with different default settings. –  Molly7244 Sep 10 '09 at 2:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.