Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Tomcat web-server running on a machine within my home wireless network, and I'm willing to connect to it from other devices/machines. The problem is that the only way to access web server is via localhost or my-computer-name -- only from server's machine. The strange thing is that:

  • I can ping 192.168.16.103 (my server's IP) -- from any machine
  • .. but 192.168.16.103:8080 is not accessible even from server machine itself

I know it sounds as a basic firewall issue, but I have turned it off, and even (just in case) tried to switch all network-related shields of my antivirus. All the rest configuration (including wireless router) is pretty much standard, except for router's gateway ip set to 192.168.16.16.

At this point I'm stuck, and can't figure out what's the problem.. maybe some router settings that I've missed. The router is TP-LINK TL-WR741N.

Any help appreciated, thank you.

EDIT The OS is Windows 7

share|improve this question

migrated from serverfault.com Feb 8 '12 at 22:40

This question came from our site for professional system and network administrators.

    
If the port ISN'T "accessible from the server itself", then I'd guess it isn't really running on port 8080. –  uSlackr Feb 8 '12 at 22:06
    
It is running on 8080. localhost:8080 works fine, ipconfig tells machine have IP 192.168.16.103, but 192.168.16.103:8080 is not accessible. It obviously goes through a gateway and gets lost, and I don't know why -- that's why I seek a help here. –  Arturs Licis Feb 8 '12 at 22:14
    
What is the OS running Tomcat? –  Nick2253 Feb 8 '12 at 23:01
    
The OS is Windows 7 –  Arturs Licis Feb 8 '12 at 23:03

1 Answer 1

up vote 2 down vote accepted

Sounds like Tomcat is not listening on the server's 192.168.16.103 address but only on localhost. Take a look at the "address" field in the tomcat configuration and ensure it is listening on all addresses.

share|improve this answer
    
I already did, it's not the case.. By default Tomcat doesn't restrict to localhost only, and I have not changed anything. Just in case I double-checked server.xml, there're no restrictions. –  Arturs Licis Feb 8 '12 at 22:33
    
What does 'netstat -an' show you about port 8080? –  uSlackr Feb 8 '12 at 22:36
    
TCP [::]:8080 [::]:0 LISTENING, and several entries like TCP [::1]:8080 [::1]:61146 TIME_WAIT –  Arturs Licis Feb 8 '12 at 22:43
    
Looks like its only bound to IPV6. try changing net.ipv6.bindv6only=1 to 0 in the config file. More here:lists.debian.org/debian-user/2009/12/msg01261.html –  uSlackr Feb 8 '12 at 23:10
    
I'm using Windows 7. Indeed, IPV6 was on. I've disabled IPV6 in Wireless Network Connection Properties, but it didn't help. Maybe there's some else IPV6-related configuration item I should toggle? –  Arturs Licis Feb 8 '12 at 23:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.