Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In recent update of Google Chrome internet browser (in stable channel), there is a new security/privacy option:

In addition to checking a list of known bad files, Chrome also does checks on executable files (like ".exe" and ".msi" files). If the executable doesn't match a whitelist, Chrome checks with Google for more information, such as whether the website you're accessing hosts a high number of malicious downloads.

According to more detail link

If a file isn’t from a known source, Chrome sends the URL and IP of the host and other meta data, such as the file’s hash and binary size, to Google.

What if I want google not to know which executable files are downloaded by me and from?

How can I disable sending to google URLs and hashes of .exe and .msi downloaded?

share|improve this question
Probably part of "enable phishing and malware protection" in settings. Chrome is headed toward being just another bloated browser, so sad. – Moab Feb 9 '12 at 2:46
Also see… – Moab Feb 9 '12 at 2:48
As long as I can opt-out, I'm cool. Chrome is getting bloated a bit, but it's still a good browser. – Camilo Martin Feb 12 '12 at 3:56

3 Answers 3

up vote 11 down vote accepted

Within the blog post you linked to, there is a a link that explains how to disable the 'safe browsing' features.

Turn off phishing & malware warnings

The following steps will turn of phishing and malware warnings, as well as download warnings.

  • In the top-right corner of the browser window, click the Chrome menu Chrome menu.
  • Select Settings.
  • Click Show advanced settings.
  • Under "Privacy," uncheck the box "Enable phishing and malware protection."
share|improve this answer
yes, but this page says nothing about "download scanning", so I think, it is not for disabling "download scanning" and sending url to google. – osgx Feb 13 '12 at 0:13
in the page i linked to above, follow the instructions under "Disable phishing and malware detection". – obsd Feb 13 '12 at 1:21
will it disable downloads checking too? How can you prove? – osgx Feb 13 '12 at 2:12
presumably so. your second question is ambiguous. – obsd Feb 13 '12 at 2:30
You can choose to keep individual files by clicking "recover malicious file" in the downloads list after they are blocked. I would do that on a case-by-case basis rather than disabling protection completely. I don't think disabling security settings is the greatest advice, even if it is in a Google blog post. – Jason C Feb 28 at 0:08

An additional option is available. If you've downloaded a file and Chrome has blocked it, and you'd like to keep the file without disabling malware and phishing protection altogether, you can keep the file like so:

  1. Download the file and let Chrome "block" it. If you are directed to a "site ahead contains harmful programs" page, click "details" then "visit the site".

  2. After chrome displays the warning message in the download bar, click "show all downloads", or choose "downloads" from the menu, or press "ctrl+j" (on Windows at least).

  3. The file will be in the download list. Click "recover malicious file". Then it will get that file.

This way you can keep your security settings but still make a decision about an individual file, which is generally the safer way to go instead of disabling the protection completely just for one or two files.

share|improve this answer
The question was about: how to stop Google from spying on my downloads. Your solution is good for unblocking files, but not for stopping the spy functionality. – osgx Feb 28 at 4:36
Great solution for one-off downloads. – WirthLuce Nov 3 at 4:16
Is there a way to do it permanently? It looks like Chrome removed the checkbox from the other answers. – Gaʀʀʏ Nov 12 at 14:41
@G Well, you could use a different browser, I suppose, heh. – Jason C Nov 12 at 15:29

Here is a fix. Go to the icon that has 3 horizontal lines in the top right corner, right under the X -> go to stting near the bottom -> scroll down and click "show advanced setting" -> under the privacy section, uncheck the 5th box that says "enable fishing and malware protection"

share|improve this answer
'fishing' lol... – developerbmw Apr 3 at 5:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.