Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Seagate Flexdrive, onto which I save my backup Windows 7 images. To test that system image restore worked, I tried a dummy run. When I booted system restore disk, it said that it could find the NAS drive. I'm assuming that its system restore disk does not load up network drivers. Anyone know what might be causing this or have a workaround?

share|improve this question
Are you using wired or wireless NAS? – Moab Feb 9 '12 at 4:04
its a wired NAS. – madphp Feb 9 '12 at 4:21
Yes Windows RE loads wired network drivers for your nic. – Moab Feb 9 '12 at 4:44
up vote 4 down vote accepted

When you select "System Image Recovery" from the tools list in Windows RE, it will give and error "Windows cannot find a system image on this computer", click "cancel" then "Next" then "advanced" button, here you will be able to search for a network location or load a driver for your NAS if it is needed.


enter image description here


enter image description here

share|improve this answer
Doesnt work. Cant access NAS drive. I get the login to popup but known user/pass not working. Ive tried using IP and NAS hostname. Also, switched off windows managing of homegroup connections. – madphp Feb 12 '12 at 22:01
get windows error when i try to logon 0x800704cf. Ive googled it but cant find anything in relation to nas drives specifically or system restore from repair disc. – madphp Feb 12 '12 at 22:12
Ok figured it out. I had to load windows drivers from motherboard software disc. Restore is running now. – madphp Feb 12 '12 at 22:34
Glad you solved it, which drivers in particular? – Moab Feb 13 '12 at 2:13
just a set of LAN drivers for onboard NIC, that came with motherboard. I should have remembered, cause windows didnt have the drivers when I first set the machine up. doh. – madphp Feb 13 '12 at 2:27

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.