Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After using a tablet for a while and disconnecting it, this weird extra artifact has appeared beside my cursor, but only on my second display. The cursor doesn't distort like mentioned in other questions I've seen here, it just has the extra bar on the left side.

weird cursor

Changing pointer theme to Windows Black or turning on pointer trails gets rid of it, but I don't really want to use a workaround.

I've tried

  • restarting (because it fixes a lot more things than it should, eh?) Didn't work.

  • reconnecting the tablet and undoing all my settings changes (I'd set the pen input area to only my first display, and turned off 'press and hold' because it was getting in the way of drawing). Didn't work.

  • shifting windows between the two displays. The cursor is specific to only the second display.

  • checking for driver updates, my mouse and tablet drivers are up to date.

  • disconnecting/reconnecting the second display. Didn't work.

The funny thing is I've used that tablet (an old Wacom CTE-640) on this machine before and I've never encountered this problem.

Does anyone have any idea what this is?

share|improve this question
    
superuser.com/questions/375266/… Check out this question, it is probably a very similar occurance. –  Psycogeek Feb 9 '12 at 8:45
    
No luck, I don't even have the Synaptics software installed ;) I need to go home, I've uninstalled SetPoint (Logitech's mouse software), let's see what happens tomorrow. –  Seyren Feb 9 '12 at 10:39
    
uninstalling the software itself might have been a bit drastic :-) originally i was thinking more along the lines of finding the offending curser grafic and changing it, or matching the grafics of the same size? or there was taking cursers out of hardware acceleration (back in xp) . –  Psycogeek Feb 9 '12 at 21:40
    
It was most of the cursors except the pointer, but the pointer had it in browser windows and not on VS2010. Weird, huh? Anyway the problem is gone, I'll now try installing the new version of SetPoint. Honestly I don't really think SetPoint was the problem though. –  Seyren Feb 10 '12 at 1:33
1  
SetPoint reinstalled, no problem. I don't think it was SetPoint. –  Seyren Feb 10 '12 at 6:56

2 Answers 2

up vote 3 down vote accepted

I've seen this suddenly occur on rotated monitors. Setting the rotation to normal and then setting it back to 90 degrees seems to resolve it.

share|improve this answer
    
I didn't think to mention that my monitor was rotated! Changing the answer to this since it fits the conditions and doesn't require disabling anything. –  Seyren May 21 at 1:30
    
This really worked! I can't believe this doesn't have more upvotes... –  Sung Kim Aug 27 at 15:28

Disable pointer shadow within the cursor menu. I was having the same issue and this seemed to fix the artifact on the second window.

share|improve this answer
    
I've never been able to reproduce the issue - I guess I'll mark this as the answer since it worked for you. Thanks! –  Seyren Dec 5 '13 at 1:01
    
Awesome. I changed up my monitors so side one is portrait flipped and there were artifacts (lines showing up) under the mouse pointer. Unticking enable shadow fixed it for me. Thanks! –  Chris K Apr 16 at 21:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.