Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just reinstalled Ubuntu with 9.04 on my laptop coming from 8.04. I have the laptop connected with a VGA output on the laptop to my flat screen monitor, which turns off the laptop screen.

Everything runs great, it's just the maximum resolution only goes up to 800x600. On 8.04 I was able to set it to 1024×768 (which is still too big for me, but it was better than 800x600).

I ran xrandr and this is the output it gives me:

ryguy@ryguy-laptop:~$ xrandr
Screen 0: minimum 320 x 240, current 800 x 600, maximum 800 x 600

Is there anyway I can set it to 1024x768, or even better would be 1280x1024? I know the monitor is capable of such resolutions.

Laptop information:

Toshiba Tecra 8200. On the bottom it says:

P850,14,256,10,C.M/L 
PART NO. PT820U-01DSGB

I've been searching for drivers on Toshiba's support site but I can't seem to find this specific laptop. For example, it asks for the laptop's product series (gives the options A, M, R, and S) but I can't seem to find that on the laptop anywhere.

This is the driver site: http://eu.computers.toshiba-europe.com/innovation/download%5Fdrivers%5Fbios.jsp?service=EU

share|improve this question
    
make and model would be helpful for us to know :) –  Molly7244 Sep 10 '09 at 2:13
    
Here's the link for the laptop's specs: toshiba-europe.com/computers/products/notebooks/tecra8200/… –  RyanScottLewis Sep 10 '09 at 2:43
    
Okay, the closest model I could find on the official drivers was PT820E and they were all Windows drivers. =/ –  RyanScottLewis Sep 10 '09 at 3:00

2 Answers 2

Edit your xorg.conf to reflect the correct settings - drop into Terminal and run this command :

sudo nano /etc/x11/xorg.conf

You should be able to find the external monitor settings under Monitor section (be sure to correctly id that it's the vga out in the "Identifier" section.

Change the settings to accurately reflect the settings you want.

share|improve this answer
    
Alright I ran "sudo gedit /etc/x11/xorg.conf" (nano scares me >_>) and xorg.conf is completely empty. Same when I open it up in nano. –  RyanScottLewis Sep 10 '09 at 2:38
1  
Can you try to tell Ubuntu to reconfigure xorg (and hence generate an xorg.conf file)? run dpkg-reconfigure -phigh xserver-xorg –  caliban Sep 10 '09 at 5:42
up vote 1 down vote accepted

I finally got it! After 4 hours I friggin' got it!

I had to add:

HorizSync        24-80
VertRefresh      55-75
DisplaySize      405.18 370.44

to the "Monitor" section. Had to get my actual monitors specs to do so. =D Thanks for giving me a headstart on this though.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.