Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Google calendar of events for our local elementary school. I've made a month view publicly viewable, but it shows events in GMT rather than in US/Eastern timezone.

My settings and the calendar's settings have the time zone set properly.

Why is this showing in GMT?

Is there a way to explicitly set the time zone for display?

share|improve this question

5 Answers 5

In calendar properties you can set it up there when you share it. Are these events yours or someone else adding them, which may account for the GMT?

share|improve this answer

If you click settings under the calendar, you should be able to set time zones and other localisation settings.

If the shared calendar is the only one showing incorrectly, maybe you have to login to the account that is sharing it and change it there.

share|improve this answer
    
The account's settings and the calendar's settings have the time zone set properly. –  Doug Harris Sep 10 '09 at 2:35

Could you explain exactly which sort of "month view" you've made publicly available? (A URL would be ideal :) Are you looking at actual web pages, or is this a calendar feed of some description?

Single occurrence events are stored as UTC, so that may be what you're seeing if you're looking at relatively raw data.

If you're embedding the calendar using an iframe (via the "Embed this Calendar" option) then you need to set the time zone there, too. If you follow the link saying "Customize the color, size and other options" (or something similar) there's a time zone option in the bottom left.

share|improve this answer
up vote 1 down vote accepted

It turns out the link to the view had an explicit time zone of UTC as a query parameter. It's odd because I never put it there and (I'm pretty sure) it used to work properly.

share|improve this answer

Update your HTML code in [Embed This Calendar]

  1. From your site.google, Remove your previous "Public Google calendars"
  2. Go to Calendar Settings
  3. Select Calendars tab
  4. Click your calendar account (your Gmail)
  5. Click "Customize the color, size, and other options"
  6. Check mark all calendars
  7. Select "Time Zone"
  8. Update HTMT (locate on top right corner)
  9. Copy all of the HTML strings (codes) in the box
  10. Paste these code into your website (Step 5, right side)
  11. Save
  12. Now you can re-insert your calendars into site.google
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.