Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had several rules set up in Outlook, all worked fine, but I just recently switched to a new user account on the same machine and ever since then, my rules have not been working 100%. Most of my rules move a message to a folder and mark the message as read, but what's happening is the message will move to the folder, and only some will be marked as read. It's very strange and almost seems like a bug. I tried deleting one of the rules and recreating it with no luck, then I tried splitting it up into two rules so the message would be marked as read first, then moved to the folder, but this has not fixed the problem either.

As I said, my rules all used to work fine so I know they were initially set up correctly - I'm just not sure why they became messed up, or how I can fix them.

UPDATE 5/9/2012: In addition, If I go into the "Rules and Alerts" menu and select "Run Rules Now," all rules work as expected.

share|improve this question
add comment

3 Answers

This may seem drastic, but it may also help. First of all, back up all the PST and OST files you may have, I'd even say backup your NK2 files as well.

Next, delete your outlook profile. That's right, Control panel, mail and then remove the profile. (AFTER THE BACKUP)

Recreate the profile from scratch. Add one account at a time and setup rules for the account.

Drastic, yes, but should fix the issue.

share|improve this answer
add comment
up vote 0 down vote accepted

My folder size was ~6GB so I cleaned it up and reduced it to around 100MB. Since then my rules have been working correctly, so it looks like the large folder size was the problem.

If you are having this problem you can check your folder size in the left-hand margin's "Mail" pane by right clicking on the root node, in my case, "Personal Folders," selecting "Properties...," then clicking the "Folder Size" button.

When I switched to my new user account, as mentioned in the OP, I grouped some stuff together for the migration which increased the folder size and explains why it started at that point.

share|improve this answer
add comment

What if you export the rules, delete them all, then import them anew?

To try this:

  1. In Outlook select Tools⇨Rules and Alerts
  2. Choose Options
  3. Choose Export
  4. Save the .RWZ file somewhere you can find it later
  5. Delete each Outlook rule one at a time (you didn’t say how many you have—this part could take a while)
  6. Restart Outlook
  7. Go back to Tools⇨Rules and Alerts
  8. Choose Options
  9. Choose Import
  10. Navigate to and select the .RWZ file you saved earlier
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.