Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Using the command

gedit /etc/apache2/httpd.conf

produces a text file containing just one line. I need to change the DocumentRoot of my Apache configuration so as to use with the CakePHP framework.

share|improve this question
    
Seeing you already posted two questions about almost the same topic, I suggest you do some reading/searching before asking. – m0skit0 Feb 9 '12 at 15:16

On Debian-based systems (which Mint is), the Apache configuration takes a different approach. Every "site" has its own configuration in /etc/apache2/sites-available.
The default configuration is named default. So, try:

gedit /etc/apache2/sites-available/default

Don't forget to reload or restart Apache afterwards:

sudo invoke-rc.d apache2 restart

As a sidenote, you can create additional configuration files in /etc/apache2/sites-available and activate them using:

sudo a2ensite <yourconfig>

You can disable the same configuration with:

sudo a2dissite <yourconfig>
share|improve this answer
    
Sorry, I am newb and what you explain really confuses me, I am new to php and webserver setups as well all Linux commands. What is 'site-available' ? Could you help me configure use of cakephp with apache on Mint via localhost:80. I use this only to test some things I learn. – Thach Xuyen Feb 9 '12 at 15:03
    
sites-available is just another folder on the hard drive. Instead of opening httpd.conf in gedit, you have to open another file in a nested folder (that file is named default). I wish I could provide you with some screenshots, but I'm having some trouble with that. – Oliver Salzburg Feb 9 '12 at 15:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .