Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Windows Vista, whenever I open a folder, the selection of columns is nonsensical: album, date taken etc for folders that contain no music or pictures whatsoever. I can select the correct columns for a particular folder, but all the other folders are still wrong, even when I go in to Folder Options and click the button to set the current options to all folders of this type.

How can I tell Windows to use the current column selection for all folders, unless otherwise specified?

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

eZine Article: Setup a Default Folder View in Windows Vista talks about some registry stuff along with the points in Daniel's answer. Below is from this link

One of the problems many people face once they have installed Vista is that their folder view will change every time they close and reopen a folder. This is annoying right?

Well here is the solution:

1 Open the registry: Simply click on the start orb and type in "regedit" into the search field. A file called regedit.exe will show up at the top, double-click it!

2 Locate the following folders in the registry editor by clicking on the small black arrows to expand the folder structure:

[HKEY_CURRENT_USERSoftwareClassesLocal SettingsSoftwareMicrosoftWindowsShellBags]

[HKEY_CURRENT_USERSoftwareClassesLocal SettingsSoftwareMicrosoftWindowsShellBagMRU]

3 Right click on the folder "Bags" and click on delete, do the same for BagMRU. This is how you get rid of disturbing folder view entries. Don't worry we will now create a new one called "DefaultFolders".

4 Right click on the folder "Shell" that is the parent folder of the folders you just deleted.

Click on "New" -> "Key". Name it "DefaultFolders".

5 Repeat 4. but for the folder we just created and name the new folder "Shell". That way you will create a subfolder "Shell" inside the folder "DefaultFolders".

6 Now we right-click on the folder "Shell" and create a new String: "New" -> "String Value".

Give the string the name "FolderType".

7 Double-click it and type "Documents" into the value field.

8 Almost done, now all folders will have the same folder view as the "Documents" folder. Time to set your default folder view. To do that open up the explorer (Windows-key + E is the shortcut).

Now locate C:UsersYour_User_NameDocuments, where C: is the partition on which you installed Windows obviously. Make sure to set your favorite folder view (mine is Details) there.

Click on "Organize" -> "Folder and Search Options".

Now go to the tab "View" and finally click on "Apply to Folders"!

I have used the steps from Daniel's answer on Windows XP machines.
If they do not work on the Vista, try the eZine article.

Meanwhile, this Vista64 thread suggests Vista SP2 has solved this problem.

share|improve this answer
    
SP2 didn't solve it. SP3 (Windows 7) did. –  user3463 Sep 10 '09 at 11:17
add comment

First you set the columns the way you want in one folder, then on the Tools menu (Alt+t if the menu is hidden by default), click Folder Options... and then go to the View tab, click Apply to Folders. After confirming, you will see that all your folders (at least of that type) have been changed.

PS. Thanks for asking; it reminded me that I needed to set this up.

share|improve this answer
    
This will work for some time and then foul up. You need to combine this with my answer for it to "stick". –  harrymc Sep 10 '09 at 14:43
    
FYI this works in Windows 7 (without the need for the patch). –  glenneroo Feb 20 '12 at 12:45
add comment

See this article from annoyances.org : "Default Folder Template Patch", which says:

Windows Vista has a bug that prevents it from choosing the correct view for a folder based on its contents, which is why you may see thumbnails when they're not appropriate, and no thumbnails when they're needed. The following patch stops Vista from trying to guess how to display a folder, instead forcing it to use the template of your choice.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.