Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am very fond of digiKam. I am. Together with photivo I believe they're the two most competent programs to edit RAW photography. But the looks on digiKam don't convince me. At least not on Ubuntu 11.10. I've been trying to solve this problem, attempting to make it look a bit more sophisticated, but nothing seems to do it. I found these instructions on the digiKam site, but they don't suit me as I can't afford to put in the time and effort that crafting a new theme requires. Also, this discussion appeared to be promising, but it's proven to be feckless; the few users there each state they have the same problem, but nobody really gives the solution. Remember that I am running Ubuntu 11.10 with the Cinnamon desktop environment. Here's a screenshot of digiKam, and below that one there's a shot of the much better-looking photivo. If I can get digiKam anywhere near that, it's a win for me. In fact, even changing something about its appearance would do it! Thanks in advance.

digiKam running on Ubuntu 11.10 (Cinnamon desktop)

photivo under the same OS

share|improve this question

2 Answers 2

up vote 1 down vote accepted

What you need to do is change the gtk theme. This will change what the widgets that digiKam uses look like.

On Gnome 2, I would say:

  • use System -> Preferences -> Appearance
  • if a good dark theme isn't there:
    • look at the package manager and check for gtk themes that you could install
  • if none of those are what you want:

I think that some of this might apply to Gnome 3 but YMMV.

share|improve this answer
    
Thanks for your help, Dan. I had read this somewhere, though. It doesn't look like a real solution to me, since I'm not changing anything within the program itself, just the way the desktop environment renders it. If I logged onto say, Unity, the program would look the same, wouldn't it? –  the.midget Feb 10 '12 at 11:56

This has worked for me: "To add themes, you will have to install an extra pack­age (as decribed here) like this: sudo apt-get install kde-workspace-data" source: http://svenbuschbeck.net/wordpress/2012/05/add-themes-to-digikam-without-kde/

blessings!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.