Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to make gnome-terminal transparent. To do this I have to select option Transparent background and move the slider under Background tab from the menu - Edit -> Profile Preferences. It becomes transparent but only the desktop wallpaper is shown in the background.

But I want to see actual open applications or windows on the background. How do I do this? (Preferably in Ubuntu 11.10)

share|improve this question

migrated from stackoverflow.com Feb 10 '12 at 11:21

This question came from our site for professional and enthusiast programmers.

    
This ... isn't a programming question. –  Brian Roach Feb 10 '12 at 6:36
    
You have to activate desktop composition (e.g. Compiz) to get "real transparency" –  Muhammad Abrar Feb 10 '12 at 6:45
    
@MuhammadAbrar- Thanks, I think compiz might work. But is there any other option which would be light on system resource? –  Harshith J.V. Feb 10 '12 at 7:09
    
@BrianRoach - Yeah this is not programming question. But I have seen lots of question on gnome-terminal in this site. Anyways gnome-terminal is mostly used for programming. So this question would be helpful for other programmers who want to customize UI, I feel. –  Harshith J.V. Feb 10 '12 at 7:13
    
Adding one more off-topic question doesn't help the site. The question is, however, appropriate for a few other stackexchange sites. –  Brian Roach Feb 10 '12 at 7:15

2 Answers 2

up vote 4 down vote accepted

This is not gnome-terminal specific but related to your system. When available, GNOME-terminal uses "X.org composition", which allows real transparency.

In distribution such as Ubuntu, this is done by enabling "Desktop Effects" and usually requires some kind of 3D acceleration.

If you have disabled all desktop effects (and using Unity-2D or GNOME3 fallback), there's no composition available. It means that GNOME-terminal cannot use proper transparency. It then make a fake transparency by getting the wallpaper from your setting and putting it as its own internal background, which might look like some transparency but isn't really one.

Solution: enable desktop effects.

share|improve this answer
    
You are right. I tried using compiz in Ubunty-Unity desktop. It worked after installing graphics driver (AMD ATI Driver). But does not work in Gnome Classic desktop is there any fix for that? –  Harshith J.V. Feb 11 '12 at 5:06
    
in Gnome Classic, I think you have to type: gconftool-2 --set --type=bool /apps/metacity/general/compositing_manager true && gconftool-2 --set --type=bool /apps/metacity/general/compositor_effects true –  ploum Feb 14 '12 at 10:13
    
Thanks man it worked. :) –  Harshith J.V. Feb 14 '12 at 12:33

If you are wanting to do this without it taking up all the resources that compiz usually uses, then in the enable desktop effects menu find the individual effects and uncheck all of them but transparency. This doesn't restrict the action to only your terminal, but its alot less intensive than the default settings.

share|improve this answer
    
Ya that should work. But since I am using Gnome Classic (No Effects) mode with transparency on I am getting what I want now. Thanks for your answer. –  Harshith J.V. Feb 20 '12 at 4:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.