Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A zombie process, which should not be using any resources (RAM and CPU), is hogging up an entire core on my 8-core 64-bit Ubuntu 11.10 Desktop installation.

This is the output of ps -el|grep Z:

0 Z  1000 10317     1 99  80   0 -     0 exit   ?        19:27:15 java <defunct>

... and here is an excerpt from top:

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                                                                                                                                                
10317 deltik    20   0     0    0    0 Z  100  0.0   1170:17 java <defunct>
 1424 root      20   0  612m 193m 158m S   14  2.4 287:17.11 Xorg
12580 deltik    20   0  710m 135m  46m S    5  1.7  27:31.07 compiz

This is how the zombie process came to existence:

  1. I opened a Java JAR called minecraft.jar. This launcher downloads another JAR file to ~/.minecraft/bin/minecraft.jar
  2. That JAR was executing when I locked my computer with xscreensaver.
  3. Then, I entered my password to unlock the computer, and I saw that the Minecraft window was frozen.
  4. I tried killing it (PID 10317) with gnome-system-monitor. It became a zombie.
  5. kill -9 10317 was ineffective.
  6. xkill only closed the window titled "Minecraft"; it didn't close the underlying java process.

Relevant information:

  • The graphics driver is FGLRX, and it has caused notorious issues with Unity of Ubuntu 11.04 and Ubuntu 11.10, including sometimes high CPU usage of Xorg and compiz.

I want to know:

  1. What way is there to destroy this process of java without restarting, if any?
  2. Why is this issue happening?
  3. What can I do to prevent this issue from happening again?
share|improve this question
I'm afraid I can't personally help you, but I commend you for doing a good job explaining what happened and what you're tried so far! – nhinkle Feb 11 '12 at 0:59
"Hey guys this application is using up a lot of CPU time. By the way, it's written in Java. Don't know if the two are related???" – Feb 11 '12 at 1:42
Most likely it's spinning on a lock. – Daniel R Hicks Feb 11 '12 at 3:59
It also happens to me while playing, @RedGrittyBrick a zombie java process running the minecraft jar and a zombie inside the game are diferent stuff. – Falk May 17 '14 at 16:34
up vote 6 down vote accepted

The process has already been reparented to init, so it should be being reaped (otherwise, the solution would likely be to kill its parent). It appears to be stuck in exit, based on the WCHAN field.

It may actually be doing something (like creating a core dump) that will finish and it will go away on its own. Unfortunately, it's likely spinning in the kernel because of a broken driver and ultimately, your only option will be to reboot.

share|improve this answer
It has been a while since I asked this question, but I was unable to recreate my problem again, especially after updating FGLRX to the latest version. I have selected this as the best answer because it points out the broken driver and is the most comprehensive. – Deltik Sep 9 '12 at 18:26

Zombie processes have died but have not yet been cleaned up (reaped is the correct term) and thus kill does not work on them like a normal process. The process is still in the process table but when it is a zombie, resources have been de-allocated.

You can try sending a SIGCHLD signal to the process parent, otherwise init should have picked it up and will reap it eventually. If you want to speed up the process you can just simply reboot.

share|improve this answer

Have you tried sudo kill -SIGCHLD 1? If this doesn't work, you'll need to reboot the system.

More on this: and

share|improve this answer

This is a kernel bug. Are you using ecryptfs to encrypt your home directory? There is a bug filed about that on

share|improve this answer
No, I manually encrypt files in my home directory. – Deltik Feb 11 '12 at 16:18

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.