Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have trying to Remote Desktop between a Win 7 machine and a XP machine. I can do this OK from within the LAN, but as soon as I try to do it from outside the network I can't.

I thought I had setup port forwarding properly but it still doesn't seem to work.

share|improve this question
    
Well, it looks like you haven't set up port forwarding properly. Check any firewalls you may be using (although the Windows one should be fine as you can connect from LAN). Are you using the right IP address when trying to connect, or are you sure that the DNS settings for the domain you are using are correct? –  paradroid Feb 11 '12 at 10:22
    
@paradroid: I can't see how I've got port forwarding incorrect. It's setup to open up port 3389. How can I tell what is going wrong? Are there some logs I can check? Can I try pinging something? –  CJ7 Feb 11 '12 at 10:36
    
Have you forwarded the port to the correct machine? You can probably find the instructions for your particular router model at this website: portforward.com –  paradroid Feb 11 '12 at 10:52
    
@paradroid: I have just worked out that it works from outside my network. I got someone somewhere else to try and it works. What I want to know is why it doesn't work if I am inside my LAN and I try to RDP using the external IP address? –  CJ7 Feb 11 '12 at 11:04
    
If you are talking about the external IP address of your router, it is probably because it does not support NAT Loopback. –  paradroid Feb 11 '12 at 19:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.