Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I built and installed Awesome WM on RHEL5. I have problem with mod4 acting like its always pressed. ie every time i hit "Enter" it acts like Mod4+Enter was hit. I have to hold down mod4 key (I remapped it to Caps_Lock) to actually send through just a Enter.

How do i fix this?

PS: If i change the WM this problem doesnt exist.


yes. I do. It is mostly tab configs though. I didnt change key combos.

Also, the version of awesomeWM i compiled is 3.1.1 (had trouble getting deps for the latest AwesomeWM on Rhel5)

share|improve this question
    
Do you have a custom rc ? – Renaud Feb 12 '12 at 10:58
    
Any more suggestions on what i should be looking into? – sgr Feb 18 '12 at 22:41

This inversion has just happened to me, but I found no answers on the internet. It ended up resulting that I had vim-eaten the line in my custom rc.lua where it stated modkey = "Mod4" and not noticed it. Once I restored this line my awesome is doing awesome again.

share|improve this answer

Are you using something as following?

setxkbmap gb -options:caps-escape

This way your Caps-Lock will change behaviour to being a simple Mod4 button. You can also remap Caps-lock to Mod4 via xmodmap, but beware that setxkbmap and xmodmap are not good friends.

Although this does not answer the question directly, I hope it will be of some to you...

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .