Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
New text files are created with uppercase extensions

New text files that are created via Explorer’s New ⇨ Text Document context-menu entry have uppercase extensions.

I searched my registry for TXT (match whole) and found nothing special. Could Notepad++ have changed this?

I am running Windows 7 64-bit and use Office 2003 and Notepad++.

How can I get lowercase extensions again?

share|improve this question

marked as duplicate by Synetech, Bob, TFM, Mokubai, BBlake Dec 2 '12 at 13:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
@Bob, May 5 '11 < Feb 11 '12. nixdagibts’ issue is a subset of Torsten’s problem and would be solved with most of the same steps. –  Synetech Dec 2 '12 at 5:52
    
@Synetech Ah, sorry. Misread 11 (without the apostrophe) as 2011. Yea, you're right. –  Bob Dec 2 '12 at 5:56
    
I know; the timestamps here can be annoying. I find the over-simplifications like dropping the current year or using “today”, “yesterday”, “five hours ago”, etc. to be irritating like what people complain about Microsoft doing with Windows. –  Synetech Dec 2 '12 at 6:02
add comment

2 Answers

up vote 2 down vote accepted

Consider trying .TXT, because extensions are stored with a preceding dot in HKEY_CLASSES_ROOT.

share|improve this answer
    
Ah very dumb by me. you are right. Now got 2 hits, deletet them, system recreates them, everything works fine. –  nixda Feb 11 '12 at 19:17
add comment

Try the following:

  • Open the registry editor (Startregedit)
  • Navigate to the key HKEY_CLASSES_ROOT\.TXT
  • Select File ⇨ Export and save it to a .reg file
  • Open the .reg file in a text-editor (e.g., Notepad)
  • Perform a search-and-replace to replace all instances of .TXT to .txt
  • Save
  • In regedit, delete the key HKEY_CLASSES_ROOT\.TXT
  • Double-click the .reg file and select [Yes] to import/merge it
  • Reboot
share|improve this answer
    
+1 Thats a good solution too. Especially if .TXT occurs very often –  nixda Dec 28 '12 at 18:17
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.