Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I usually set the search results for Google to 100; 10 is way too small for my usage.

However, when searching through the address bar of Google Chrome, it always shows 10 results, regardless of my settings. If I go to http://google.com/ first and search the same thing, it displays 100 results.

Why is this happening, and how can I get my 100 results even when searching from the Google Chrome address bar?

share|improve this question

migrated from webapps.stackexchange.com Feb 11 '12 at 17:54

This question came from our site for power users of web applications.

    
It works for me. But it only works if instant results are set to "Never show Instant results." – Alex Feb 11 '12 at 13:43
up vote 6 down vote accepted

You need to change this

{google:baseURL}search?{google:RLZ}{google:acceptedSuggestion}{google:originalQ‌​ueryForSuggestion}{google:searchFieldtrialParameter}{google:instantFieldTrialGrou‌​pParameter}sourceid=chrome&ie={inputEncoding}&q=%s

Somehow I cannot get my browser to use {parameter} style queries so here is what worked for me

https://www.google.com/search?num=100&q=%s

to include num=100 in the settings of the browser chrome://settings/searchEngines.

The settings for Google search app does not control the query to an extent within the browser itself (If you are incognito, the above query will not work).

share|improve this answer
    
This has the side-benefit that it works in Incognito mode as well. – Synetech Feb 16 '12 at 4:09
  • Log on to Google Search setting. You can set this in almost all browsers, I have tried it in Firefox, Google chrome and it worked perfectly for me. -Now look for “Google Instant predictions” , It might be second option there.
  • You can manually choose number of pages you want to see on your Google Search.

Source : Get More than 10 Results When Searching on Google Search

share|improve this answer
    
This setting is honored when first going to google.com but not when searching from the address bar in Chrome. – nos Feb 25 '14 at 10:47
    
As above, doesn't work through address bar and so doesn't provide an answer to the question. – Matthew Williams Feb 25 '14 at 11:34

Try this this bookmarklets: num=100

Google Search URL Parameters – Query String Anatomy

http://www.blueglass.com/blog/google-search-url-parameters-query-string-anatomy

Hope this help. Ley us know. :)

share|improve this answer

In addition to appending num=100 to the URL in the Search Engines entry, you can also simply log into a Google account and set your preferences. When you subsequently do a search (from anywhere so long as it is not in Incognito mode), it should do so with the parameters you specified.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .