Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed XFCE for Ubuntu and use it as my default X session. After this change some sound problems appeared:

I can mute sound with alsamixer or with hotkey on a keyboard. But just reenable it isn't enough to unmute sound.

In order to unmute it I need to:

  • go to alsamixer:
  • Mute master, headphone and speaker
  • Unmute one by one master headphone and speaker quickly and in this exact order

This is the only way I can make it work again.

The problem didn't appear when I use handphones.

How can it be?

share|improve this question
add comment

2 Answers 2

The bug is not in Ubuntu, it is in Xfce. There is a temporary fix. Open a terminal and write:

pactl set-sink-mute 1 0

And you should be good to go.

share|improve this answer
3  
I think this bug arises because of using both alsa and pulseausio. I believe when we press mute key it mutes both alsa and pulse but when try to unmute it unmutes alsa only. Therefore no sound. What your command does is it unmutes pulse-audio so sound is back to normal. –  RanRag Sep 7 '12 at 12:33
    
@RanRag Thanks for that hint. This did work for me as well. –  king_julien Mar 12 at 15:57
add comment

In graphical xfce settings editor > xfce-mixer > active-card, give your active card name.

Finding your active card

Open audio mixer for Xfce.It has drop down list of sound cards. Try and see which one is controlling Volume. Name of the card you have selected in audio mixer will appear as 'sound card' under 'xfce-mixer' in graphical xfce settings editor. Copy the 'sound card' name and paste it in 'active card' name.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.