Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

is it possible to set the autoplay to always open removable devices in windows explorer? I used the settings offered in the autoplay dialog and set the openning in Explorer for almost all content types, but after inserting a flash disk, I get the dialog again.

I need this for my visually impaired sister - for her it is not comfortable always to select the appropriate item in menu or always close it and go to My Computer.

She uses Windows 7 Pro 64 bit.


share|improve this question
Try start - control panel - autoplay and change it for each type of media. I don't know how to set it for all plug & play devices – Raystafarian Feb 11 '12 at 21:29
Hmm, this is strange - I thought I set it for almost all the items - surely for "mixed-content" - however, as I checked it, it was set to ask for action - changed to open in Explorer and seeems to be solved now. – Juhele Feb 11 '12 at 22:59
I'll add it as an answer – Raystafarian Feb 11 '12 at 23:00
up vote 3 down vote accepted

Go to Start - Control Panel - Autoplay and select the default action for each type of media. By default, Windows 7 has autorun.ini disabled for USB devices to protect against malware. If this doesn't solve your problem, you may need to enable autorun.ini and create it on the media for your sister.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.