Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

If I click on a software icon on Ubuntu, or a menu entry, and then before the program opens I quickly change to a different workspace, the program opens not in the workspace in which I clicked the icon but in the current one. This is very annoying to me. How can I try and fix that?

share|improve this question
up vote 0 down vote accepted

I think it is just part of how the desktop works... A single desktop can be divided up into multiple workspaces, but those workspaces are not as autonimous as they may seem. eg. they don't hold their own mouse position. You mouse stays in the same position as you move between the workspaces of a desktop.. And the same appears to be the case with launching apps.. An app is launched "by the desktop" and if by the time it materializes (creates its window) you have moved the terrain (workspace), then it presents itself there; in the new workspace.

devilspie is a program which tries to deal with these workspace issues... I've tried it, but don't know it very well (I found other ways to do what I wanted). It seems promising and many people like it, and it may suit your particular need.

devilspie is available in the Ubuntu repository, and there is a GUI front-end for it, called gDevilspie, availabel at

Another very useful tool (command-line) for such desktop/workspace/app manipulation is called wmctrl. It, too, is available in the Ubuntu repos.

devilspie is probably your best simplest option, because, as I've personally found out, working around this existing built-in behaviour may give a technically working result, but it can be simpler (practically speaking) to just adapt to how the desktop works as-is.
Here is a link to one such scripted workaround, which works, but I wouldn't bother using it, even though I wrote it. It is too slow and too kludgy: Hide the gnome-panel on one of the workspaces

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .