Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I shut down Windows 7, my NIC remains active and the link status LED on the router remains lit. When I shut down Windows XP, it does not. Further, rebooting XP causes the NIC to shutdown as well, while rebooting Windows 7 leaves it active.

It is not a hardware configuration issue (eg WOL setting in BIOS—which for the record is disabled) because like I said, it does indeed turn off when XP is shut down. The issue is with Windows 7.

Yes, I have already changed the settings (figure 1) for the network card in Device Manager to disable all Wake-on-LAN, Magic-Packet, etc. settings as well as checking the Allow computer to turn off this device option in the Power Management tab. I have done this in both XP and 7. (The (default) Windows 7 drivers seem to have more options than the (again default) Windows XP drivers.)

I did find plenty of hits about this issue, but not surprisingly, most of them just said to turn WOL off (and yet a lot of the askers said they already did). Strangely enough, one person actually complained that their NIC stays on in Ubuntu but turns off in Windows 7. I have the opposite issue in 7.

I have set the standby state to S3 in the BIOS instead of S1 and also used dumppo to set the minimum standby state to S3 in both XP and 7. Examining the power-setting differences (figure 2), I do not see anything relevant to the network adapter, so I am at a loss as to why 7 would force the NIC to remain active.

Update: Just to add to the confusion, I have noticed that when I put Windows 7 into standby/sleep mode, the link-LED turns off. So Windows 7 is capable of shutting the NIC off, and does so when put to sleep, but for some reason does not do so when shut down.


Figure 1: NIC driver settings in XP and 7

NIC driver settings

Figure 2: dumppo differences between XP and 7

dumppo differences

share|improve this question
    
What kind of computer is this? Notebook or a PC? What kind (if it's a PC how about a motherboard model)? So far it just sounds like 7 is using ACPI differently than XP for the S5 state (if that's in fact what you are going into when you 'shutdown'). Have you tried a BIOS upgrade? –  Ƭᴇcʜιᴇ007 Feb 12 '12 at 23:36
    
Desktop. I have set the BIOS to use only S3 for suspend (S1 left the fans and stuff on), but I don’t use suspend anyway; I usually just do a full shutdown to S5. –  Synetech Feb 12 '12 at 23:40
    
Do you have a dual boot with win7/xp, or two identical hardware machines? What NIC is it, and what driver versions is installed in Win7 and XP? For example some versions of intel Pro NIC's have different options based on driver version. Potentially one of those options/default settings could help if you identified it. –  jdh Feb 13 '12 at 1:39
    
It’s the same system. I’m using the on-board 3Com NIC with the default drivers from Windows. I’ve taken screenshots of every option in Device Manager in XP and will cross-reference them with the ones in 7 because I think 7 may have a few more options than in XP (though I have definitely set every WOL related one to off). –  Synetech Feb 13 '12 at 1:51

1 Answer 1

This is a bug in Windows 7 that is fixed in Windows 8. Shutdown is supposed to be S5 (completely powered off) but Windows 7 leaves the NICs on. Normally only hibernate / sleep should leave the NIC on and shutdown should leave the NIC off (not even Wake-on-LAN should work unless the BIOS has a setting like "Wake from S5").

Of course now, you cannot Wake-on-LAN after shutting down anymore which is a major annoyance. Most boards don't have a "Wake from S5" option. I preferred the Windows 7 behaviour.

Wake-on-LAN behavior in Windows 8

share|improve this answer
    
Sounds like a reasonable explanation, but is there a KB article or Microsoft Answers thread or something that indicates it’s a bug or is it just an opinion/observation? I have no use for WoL anyway, so I would prefer everything to be off. If it’s a bug, maybe they’ll fix it in SP2 (yeah right). ¬_¬ –  Synetech Sep 14 '13 at 13:01
    
There is a whole KB article on it. –  Locutus Sep 14 '13 at 16:59
    
A link or number would be nice. It’s not exactly obvious which one you are referring to. –  Synetech Sep 15 '13 at 1:38
    
Updated my answer with a link. –  Locutus Sep 15 '13 at 4:49
    
Thanks; unfortunately that doesn’t really explain it because that article says that Windows 7 shuts down to S5 and puts devices into D3 which means the NIC should be off, which is what I want but not getting. :-/ –  Synetech Sep 15 '13 at 15:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.