Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 7 machine that logs into a domain. The machine can net view and see the different shares, but when I try to use, net use * \\name\share, I get an error stating that the service is not started. Yet when I issue a net start, it states the service is already started. My other win7 machines work fine; they can see and use any of the shares.

Is there a security setting that needs to be disabled or enabled? I really need to get this working, and I have no other ideas as the other machines have no problem accessing the shares on different systems.

The error I am getting is , "The Workstation Service Has Not Been Started", but like I said other machines can connect fine, and when I issue a, "net start workstation", it states the service is already started. In addition the error number I am receiving is 2138.

UPDATE: On the machine that is having issues.

From the troubled machine if I issue a

Net View \\name

I can see all the shares on the machine I want to connect to. When I try to

net use * \\name\sharename

I get the error The Workstation service has not started.

I have set both settings

sc config lanmanworkstation start = auto

and

sc config lanmanserver start = auto

on the Windows7 computer that is having issues. I have rebooted the computer and still no dice. I can net view any computer on the network and see all shares, but I cannot access any of the shares in which I can see.

In the registry under the HKLM\System\CurrentControlSet\Services

Both LanmanServer and LanmanWorkstation start is set to 2.

Screen capture of net use and view:

enter image description here

The Services:

enter image description here

enter image description here

This is really weird. What am I missing? It has to be a security setting...

share|improve this question
1  
Just updated. There are no errors in the event log. –  nitefrog Feb 13 '12 at 1:30
    
good, because there are specific things that might be. –  Psycogeek Feb 13 '12 at 1:35
    
Sounds like the error message is misleading and maybe there is some corruption in the network stack. Did you try running the network 'troubleshoot problems' wizard. Also can you compare your registry settings for HKLM,SYSTEM\CurrentControlSet\Control\NetworkProvider on this machine with a working machine. –  sgmoore Nov 30 '12 at 12:25

3 Answers 3

I had the same issue (Win8). Registry was looking like this:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider] @="" [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\HwOrder] "ProviderOrder"=",npnotes64" [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order] @="" "ProviderOrder"=",npnotes64"

Compared it to another system and found my entries are different. So I changed my registry to:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider] [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\HwOrder] "ProviderOrder"="RDPNP,LanmanWorkstation,webclient" [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order] "ProviderOrder"="RDPNP,LanmanWorkstation,webclient"

That solved it. UNC paths worked again immediately.

share|improve this answer
    
I had tried restarting workstation service multiple times without help. This solution helped me too. Thanks. –  anishsane Feb 12 at 8:44

First things first. The best way to troubleshoot is to take one problem at the time.

A) Services started mode

Check if the services LanmanServer and LanmanWorkstation are started in automatic mode... If they are in manual the delay to start them may be the source of the error msg you're talking about.

B) Services Dependencies

I agree with the Psycogeek comment: the dependancies must be checked. If the service on which LanmanServer and LanmanWorkstation failed to start or are not started automatically this may add a delay in these services startup and so on...

C) Services setup comparison

Compare the services setup of a working workstation with the services setup of the problematic one...

D) Packet sniffing between the workstation and the LAN

Also check the packets transfers between this workstation and the Local Area Network to see what's really happen (or not...)

Suggested tools:

a) For services:

services.msc or mmc.exe and add services.msc (to keep your display setup) or NirSoft's ServiWin (also for drivers...)

b) For Packets sniffing:

Wireshark or Microsoft Network Monitor

If the problem comes from the services setup you have the solution.

If not, you eliminate this possibility and we can look for somethings else...

Hope this help. Let us know.

share|improve this answer
    
Don't agree with me to quickly :-) I was looking into the Crasy stuff that can happen, that make the errors meaningless. Weird stuff like Checking for %systemroot% to be working proper? Checking DCOM services (like what does that have to do with it?) and Checking Drivers themselves. Some disabled drivers can give a "service not started" that IS started. I figured everyone else would have any normal things covered :-) –  Psycogeek Feb 13 '12 at 2:12
1  
That's right! I confess that I'm too quick too often!:D With one of the suggested tools (serviwin) it's possible to check drivers (start mode and so on)... –  climenole Feb 13 '12 at 2:47
    
I tried all this and I looked at the service against a machine that works and all the same. The problem machine can net view and see everything from any computer, but cannot net use. It states the Workstation service has not been started on an net use command, even though the ACTUAL service shows started! And there are 0 errors in the event log. –  nitefrog Feb 13 '12 at 5:59
    
@nitefrog Cross compare the Drivers in device manager, with all of them showing. that means do the hidden devices tweak, and view show hidden devices on. with all that showing finnaly, look in the network devices area first. even though there could be other things. I have no idea what the problem is, it is just one more place to look. –  Psycogeek Feb 13 '12 at 6:50
    
Open in Administrator mode cmd.exe Paste in the following line: SET DEVMGR_SHOW_NONPRESENT_DEVICES=1 Then type in devmgmt.msc to start up Device Manager: in Device Manager, go to the View menu and choose Show Hidden Devices, to show all the device drivers including things that aren’t currently installed. Right-click on the driver and then choose Uninstall to remove the drivers for that old hardware. –  climenole Feb 13 '12 at 17:29

The Workstation (LanmanWorkstation) service must be started on the client machine (the one you are trying to connect from). On the server, LanmanServer is needed.

share|improve this answer
1  
All the services are started. That is the issue. It makes no sense. I can NET VIEW from the machine, but I cant NET USE from the machine. –  nitefrog Feb 13 '12 at 1:43
    
even when I type sc config lanmanworkstation start = demand and get the success response, still no dice. Remember the SERVER can be accessed by other win7 machines. –  nitefrog Feb 13 '12 at 1:47
    
@nitefrog: Right, and I wasn't asking about the server either. I was asking about that single machine that cannot access it. –  grawity Feb 13 '12 at 5:01
    
Yes the machine that is trying to access the machine that the other can has the two services started. –  nitefrog Feb 13 '12 at 5:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.