Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Toshiba laptop that I am using with an external monitor. After jumping through many hoops to get this to work in the first place, I have a problem. My previous configuration was as follows:

LVDS:

  • Disabled

VGA:

  • Enabled
  • Recommended Resolution (something like 1800/900)

Before I disconnected, I reconfigured it so that VGA was disabled and LVDS was running at the recommended resolution. It worked fine, and I shut the computer down. When I turned the computer on again, I got to the KDE login screen fine (I'm using KDM). But when I try to log into KDE, I get a black screen (though I hear the login sound). When I shutdown the computer and reboot, I can log into GNOME just fine. But when I try to log out of GNOME, everything hangs again.

Does anyone know what is going on? does anyone know of a solution to this problem?

NOTE: When I was using the external monitor, my resolution and monitor settings only took place after I logged in. Before then, it used the default settings of mirroring screens, which made the login screen bloated. This may have something to do with it.

share|improve this question
1  
Did you save the new resolution settings as default (System Settings | Display and Monitor ...set as default)? – Slobodan Kerda Feb 14 '12 at 13:25
    
No. What does that do? – Linuxios Feb 14 '12 at 18:41
    
@SlobodanKerda: If you put that in an answer, I'll accept it. It worked perfectly. – Linuxios Mar 7 '12 at 14:15
up vote 0 down vote accepted

OP solved this by setting the display configuration as the default (System Settings | Display and Monitor ...set as default).

share|improve this answer
    
Thank you. I needed an answer to accept even after I fixed this. – Linuxios Jun 6 '12 at 0:46
    
@Linux_iOS.rb.cpp.c.lisp.m.sh You're encouraged to post your own answer if you solve the problem yourself, or in situations like this. – mgorven Jun 6 '12 at 2:20
    
I know. I have done that, but I asked this before I was that comfortable with SE. – Linuxios Jun 6 '12 at 13:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .