Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to build libiphone from source on Debian Squeeze (64-bit). But autogen.sh keeps giving me this:

configure: error: Package requirements (glib-2.0 >= 2.14.1) were not met:

No package 'glib-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables libglib2_CFLAGS
and libglib2_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

I assume it's referring to libglib2.0-dev (there is no package 'glib-2.0'), which I already installed (version 2.30.2-6) as instructed by the README. Just for the hell of it, I also installed glibc-2.11-1, libglib2.0-0, libglib2.0-dev, and libglibmm-2.4-dev, to no avail. I tried running autogen.sh as root.

So basically autogen.sh is lying, because I have every conceivable glib library installed, every single one of them is >= 2.14.1, and I installed all of them from the official Debian repository. Could someone please help me figure out what's going on here?

Edit:

It turns out autogen.sh just does some minor setting-up and then runs configure. I went through configure and found the following possibly relevant lines:

In a comment titled "Some influential environment variables":

  libglib2_CFLAGS
              C compiler flags for libglib2, overriding pkg-config

In the code itself:

pkg_failed=no
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for libglib2" >&5
$as_echo_n "checking for libglib2... " >&6; }

if test -n "$libglib2_CFLAGS"; then
    pkg_cv_libglib2_CFLAGS="$libglib2_CFLAGS"
 elif test -n "$PKG_CONFIG"; then
    if test -n "$PKG_CONFIG" && \
    { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --
  ($PKG_CONFIG --exists --print-errors "glib-2.0 >= 2.14.1") 2>&5
  ac_status=$?
  $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
  test $ac_status = 0; }; then
  pkg_cv_libglib2_CFLAGS=`$PKG_CONFIG --cflags "glib-2.0 >= 2.14.1" 2>/
else
  pkg_failed=yes
fi
 else
    pkg_failed=untried
fi
share|improve this question

Try

sudo apt-get install libperl-dev
sudo apt-get install libgtk2.0-dev

Doesn't make sense but it worked for this guy.

share|improve this answer
    
Okay, installed them; autogen.sh still gives me the same error message. – Dr Kitty Feb 13 '12 at 5:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .