Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A few days ago, after bringing my USB-HDD from home and connecting it to my work PC, Windows 7 has automatically showed the "Check Disk window" (the one that you get, when you right-click on the partition in explorer "Properties" > "Error Checking" > "Check now..."). "Automatically fix file system errors" was preselected, I've additionally selected "Scan for and attempt recovery of bad sectors" and have left it do the work. My HDD is 1TB big and quite filled so I knew that the whole process will take some time but after seven hours I've lost patience and have tried stopping it by clicking "Cancel" button in the aforementioned window. With no effect. Then I've disconnected the USB cable and the "Check Disk" window has disappeared.

Thinking that everything is fine, I've started organizing the directories and, in particular, I've moved (not copied)




which also contains directory named A. I wanted to merge these directories. But, instead of showing me the usual merge window, Win 7 has showed me some other window that I've confirmed without reading it (because I was in hurry).

Problem is: In X:\B\A I now have everything from X:\A but not a single file or directory from the old X:\B\A. I've tried four applications for data rescue (commercial "EASEUS Data Recovery Wizard Professional 5.5.1", freeware Piriform Recuva and NTFSUndelete and open source but they all "only" find files that I have intentionally deleted long (and not so long) time ago.

Interestingly, Win 7 explorer shows "58.7 GB free of 931 GB" but when I mark all directories and files in the root of X:\ and right-click "Properties" it shows me that the size is 788 GB. HA! So they are there (or at least I think they are): 931 - 788 = 143 - 58.7 = 84.3 (which could roughly be the size of X:\B\A prior to the move). I also want to point out that I've run chkdsk in safe mode (with command line only) but the files were not recovered (the best part is that there were no errors!).

One last remark: I have not changed anything on the HDD since the incident.

My question: I there a way, any way, to rescue my data? Thank you very much for any help that you provide.

UPDATE: After installing every possible application for data rescue GetDataBack for NTFS (v4.25) has brought me a step closer to my data. I can finally see and open them (it's a demo so, not all files can be copied and opened). But, yes, they are there. It seems that MFT was damaged. Now, can I repair MFT as GetDataBack shows me MFT entry no, parent MFT entry, MFT location, first cluster, first sector?

share|improve this question
Your question makes no sense. – Ramhound Feb 13 '12 at 13:59
@Ramhound: Why it makes no sense? – Brian Johnson Feb 13 '12 at 15:16
Why not buy getdataback and recover your files? – Moab Feb 13 '12 at 15:41
@Moab: That's an option on the list. I'd still need to somehow "tell" to Windows to "free" 80GB (which is the size of the directory I'm trying to rescue). That's why I'm trying to find a tool to help me somehow "re-attach" that directory in the file system. – Brian Johnson Feb 13 '12 at 16:04
recover the files to another drive, back up the other files to the other drive, then format the problem drive and copy the files back to it. – Moab Feb 13 '12 at 20:05

Your loss files may be hidden or super hidden? Try this from command line:

attrib -S -H X:\B
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .