Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Just a random windows annoyance... when I move a file from one directory to another it works as expected. When I move files from the desktop, apparently that's Special™ and windows throws a little lock icon on it, and it's no longer accessible by Everyone.

I'm sure this is for the security health of my PC and there's some very sensible reason for it but honestly I just want to disable the behavior so I don't have to keep manually changing permissions. Does anyone know how?

share|improve this question
1  
Desktop is tied to a specific user account, since W7 user accounts are protected it does this, I suppose you could add everyone to the security settings of the desktop folder for that user, but I don't recommend this. –  Moab Feb 13 '12 at 15:54
    
That appears to have done the trick. I'm gonna be a wild gambler and keep this setting... The files had "everyone" permissions before moving to the desktop anyway. Hope there aren't any funky unforeseen consequences. –  CreeDorofl Feb 13 '12 at 22:21
    
Could be security implications, not sure. MS probably does this to cut down on malware infections. –  Moab Feb 14 '12 at 4:32
    
Granting "everyone" rights is not a good choice. There is one exception: This pc you are speaking of is completely isolated and has no connections anywhere. Which version of Windows do you use? I tried it myself and it does not happen (using Windows 7). –  Tom Feb 14 '12 at 12:49
    
On the one hand I'm probably being dumb to make this change. I once changed my entire C: drive to "Everyone" and it caused a disaster. On the other hand I'm just sick of dealing with the lock file issue. I'm on win7 64 bit. To recreate the issue, just move any file that currently has, say, everyone permissions on it to the desktop. Then move (or cut/paste) from the desktop and to any other folder. It will lose "everyone" permissions and show a lock icon. If it matters I'm moving from the actual desktop, not via explorer C:\users\username\desktop. –  CreeDorofl Feb 14 '12 at 16:25
add comment

1 Answer

up vote 0 down vote accepted

Desktop is tied to a specific user account, since W7 user accounts are protected it does this, I suppose you could add everyone to the security settings of the desktop folder for that user, but I don't recommend this.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.