Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am very new to Linux , we are trying to install Emacs editor on linux which is Red hat Linux5.

We setup VMWare and installed linux on that , i tried google a lot and couldn't find any tutorial on how to install emacs on Linux.

I am totally new to linux , can someone explain how to do the same.

It will be of great help thanks.

share|improve this question

migrated from stackoverflow.com Feb 13 '12 at 20:45

This question came from our site for professional and enthusiast programmers.

Did you try yum install emacs ?

share|improve this answer
    
wow that command works but it says the following error 192.168.0.5/pub/server/repodata/respond.xml timedout – kobe Feb 13 '12 at 4:24
    
and then it said trying other mirror , error: Cannot open /read repomd.xml file for repository:core , – kobe Feb 13 '12 at 4:25
    
to give you more info , i am able to browse on my vm through firefox – kobe Feb 13 '12 at 4:27
    
You have to run yum as root. Do you have root access? – jjlin Feb 13 '12 at 4:31
    
yes i only installed that , i am running this command from root only , how can i check that? – kobe Feb 13 '12 at 4:40

If you're getting emacs: error while loading shared libraries: libXfixes.so.3: cannot open shared object file: No such file or directory when starting emacs, do:

yum remove emacs
yum install emacs-nox
share|improve this answer
    
Isn't the package manager supposed to automatically install all needed libraries when the emacs package is installed? – grawity Sep 16 '14 at 5:06
    
I dunno; it didn't happen in my case — I first tried doing yum install emacs as per the other answer, but that resulted in the error as above being generated when then trying to start the emacs. I had to install emacs-nox and also remove emacs in order for emacs to work. – cnst Sep 16 '14 at 13:06

If your RH VM hasn't connection to repository you can download rpm package and install it locally. For example:

rpm localinstall emacs-21.2-2.i386.rpm
share|improve this answer
    
I believe you've confused yum/rpm. – Aaron Copley Feb 13 '12 at 20:58

You must log in to answer this question.