Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Strangely my terminal has funny characters in the date area that look like Russian. Does anyone know why it displays these characters?

(I'm running Mac OS X Lion)

share|improve this question

migrated from stackoverflow.com Feb 13 '12 at 22:39

This question came from our site for professional and enthusiast programmers.

    
what are you trying to view? –  Brian Feb 13 '12 at 22:19
    
Yes, this is Russian )))) –  mikithskegg Feb 13 '12 at 22:20
1  
Why is Russian output in contradiction with having Mac OS X Lion? Is it a specifically non-Russian OS? –  larsmans Feb 13 '12 at 22:22
1  
Maybe your locale is somehow set to Russian? Does it change to English if you issue the command LC_ALL=C ls -l? –  ChrisJ Feb 13 '12 at 22:24
    
Russians go ))) –  mikithskegg Feb 13 '12 at 22:25

1 Answer 1

up vote 0 down vote accepted

Turns out I had a line in my .bash_profile that was setting my LANG to russian. Must have been from a bad copy and paste job from somewhere!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.