Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Just now I downloaded the latest Linux kernel from the official site. With it I downloaded the .sign file. I found instructions on-line for how to check the file against the PGP signature. It's the first time I'm doing something like this; I intend to compile the kernel to make it capable of reading exFAT file-systems.

However, when I want to check the file against the signature, I run into an error. I did as instructed but I get the following:

a snapshot of the error from the terminal

P.S. I don't have a clue as to what the problem is here, for I have never dealt with PGP personally before. I am not asking about how to make Ubuntu read exFAT, please don't try to go that way and ignoring this PGP hassle. I want to compile the kernel and this is what is standing in the way now, so please help me solve this problem. Thanks for narrowing your answers.

share|improve this question
    
It doesn't look like gpg is failing but rather the file is inaccessible. Check the permissions and group settings for both files. – Andrew Lambert Feb 14 '12 at 5:49
    
@Amazed Hey, that's not the problem at all. I checked the permissions, they're all right. I also run the command as root; same results. I did this before I posted the question. – the_midget_17 Feb 14 '12 at 17:06

Try downloading it again. With wget. Perhaps the download wasn't perfect. Does it even untar/unxz without any errors? You also don't need the archive in your command line. Just include the .sign file and have them in the same directory.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .