Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Windows 7, when I have multiple monitors extending my desktop, there is functionality to activate a certain monitor by pressing Ctrl+[monitor #]. So if I press Ctrl+2, then the current program jumps over to the monitor identified as monitor 2. I'm sure this functionality serves a good purpose, but it can be rather annoying in programs that rely on Ctrl + [number] for other functionality.

Is there a way to disable this feature in Windows?

share|improve this question

migrated from stackoverflow.com Feb 14 '12 at 4:25

This question came from our site for professional and enthusiast programmers.

9  
[Ctrl]+[Number] as described is not not a Windows feature. Do you have any third party applications that may have assigned this hotkey? Perhaps graphics driver or display managing software? – iglvzx Feb 14 '12 at 4:39
    
Correct. By default, in Windows, you can move open windows across monitors using the Snap functionality, as described here: 7tutorials.com/… You must have something installed that allows you to do what you described. Uninstalling it will "fix" your "issue". – Corporate Geek Feb 15 '12 at 9:41
    
maybe you should considering about use third party application. :) – RawR Crew Jun 1 '12 at 15:30
1  
Please see How can I determine which process owns a hotkey in Windows? to find out what's causing this behaviour. You can add your own answer with what it turned out to be. – Bob Jun 1 '12 at 15:35

Found the Super Utilities running in my notification area. It’s the Multi-Display Control Panel utility where you can set the “Hotkey to move Window between Display”.

I simply reassigned the hotkeys for now.

share|improve this answer
    
can you clarify this a little more? – Malachi Oct 19 '12 at 21:52
    
Thank you so much this was doing my nut in, as ctrl-1 is the keyboard short cut for auto fix in Eclipse... – Omar Kooheji Oct 22 '12 at 14:55
    
@Malachi Right-click on the "Super Utility" icon in your system tray, select "Multi-Display Control Panel", click Disable. – Geoff Mar 28 at 18:34
    
3 and a half years and I get a response! lol thank you, I was hoping the answerer could incorporate more information into their answer. – Malachi Mar 28 at 18:38

Thanks for point me in the right direction, user137553.

Reassigning the keys didn't fix it for me, but I found that the MCTDUtil process was responsible for Super Utilities, and when I killed in via Process Explorer the problem when away.

I used CCleaner to disable MCTDUtil from getting launched at Startup, and my CTRL + 1 and CTRL + 2 hotkeys are working correctly now in Outlook and Firefox!

share|improve this answer

This "utility" was switching my screens when I hit the hot keys, whether or not I was also holding down CTRL or ALT or SHIFT.

I couldn't find any way to directly uninstall it, but located the file responsible in this directory: C:\Program Files (x86)\Common Files\DesktopUtil

I changed the name of the DesktopUtil folder to _old_DesktopUtil and now Super Utility no longer runs at startup. Headache solved.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .