Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Sphinx search server(version 'Sphinx 2.0.3-id64-release (r3043)' from http://sphinxsearch.com/) in my Rails app with thinking_sphinx gem. Sphinx starts automatically when I reboot and I can't stop it. I tried sudo searchd --stop but the process just respawns itself.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Stop (as manual start too) requires --config parameter.

If you start sphinx with command searchd --config=file, you can stop it with searchd --config=file --stop. Try to determine your start command argument.

P.S. Better late than never :)

You can also send a signal kill -9

share|improve this answer
    
Thank you. I'm not using it anymore but hope that helps somebody else. –  RocketR Dec 15 '12 at 20:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.