Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Google from Germany, occasionally I get it in German, but once I log in it goes back to English, as from my setup.

Today, as a logged in user, I performed a search of "Google bookmarks", I clicked the result, and the page contained my bookmarks, but it was localized in Polish. Does anybody have an idea of what's going on?

share|improve this question

Because google uses geolocation. If you have default EN browser and Polish locale and UK timezone while in germany it will simply vary between them

share|improve this answer
1  
Well that would make sense if I had polish locale, which I have not. Also, all the computers in the lab behaved in the exact same way, regardless of operating system or browser. – Stefano Borini Feb 16 '12 at 22:59

Most of the Google pages can be forced to show up in a given locale just using an additional parameter (hl) on the URL Just like this (change en for the desired language):

http://www.google.com/?hl=en

share|improve this answer

Open your browser's options. Go to managing Cookies then search and delete cookies relating to "google". This should reset your settings.

share|improve this answer

your ISP (internet service provider) might have given you an external IP that is in poland or close, check with whatismyip.com's what my ip says about me

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .