Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question has already been asked here; but the answer only gives advice on how to view the email header not the actual html source of the email.

There is another question here, which I think may be caused by the same issue as mine, but does not have a satisfactory answer (the answer does not work for the person who posted the question)

If I right click on the bottom of an email I can see the option to 'view source' but when I select it nothing happens.

I have done a bit of research and came across a post for a much earlier version of Outlook that suggested adding something into the registry. I applied this advice, but it made no difference; but I'm pretty sure that applying this solution correctly for my circumstances will do the trick. When I first received this machine it had a demo version of UltraEdit installed. I uninstalled UltraEdit and installed Notepad++ instead. I am convinced that there is a registry entry that is pointing to UltraEdit as the default view for 'view source' in my email and I need to replace this entry with a reference to Notepad or Notepad++, but I don't know how to do this.

Any suggestions?

share|improve this question

8 Answers 8

Actions>>Other Actions>>View Source works for me. It invokes Notepad and shows the full html source.

share|improve this answer
    
It doesn't work for me :-( See what I have added about a missing reference in my registry above. –  Martin Duys Mar 16 '12 at 8:46
1  
What application do you have associated with .htm & .html files in Windows? Do both filetypes open up properly when opened via Explorer? –  Lunatik Mar 16 '12 at 9:36
    
They were both set to Chrome and I have changed them both to Notepad++ Both open fine in Notepad++ when doubleclicked –  Martin Duys Mar 16 '12 at 10:37

Double click on the mail, this will open it in a new window.

After that, then click on File > Properties. You will be able to see the header information from there.

For the "view source", right clicking on mails that have a source will by default open it in notepad.

For mails that aren't formatted (in HTML etc), the "view source" option will be greyed out.

share|improve this answer

Best option if you need to do this more then once. Click File > Options > Quick Access Toolbar > Choose commands from "All Commands", In the list, find View Source, Add it and click OK

Now you have an icon to always view the source no matter what kind of email.

If the icon is grey-ed out, it means the email type is txt and has no source. Found in http://www.outlook-tips.net/tips/view-message-source-outlook/

share|improve this answer
2  
There is no "View Source" to add. –  N13 Feb 26 '13 at 17:55
    
@N13, did you select "All Commands" from the drop down? It defaults to popular actions –  jsims281 Nov 27 '13 at 10:39
    
same here - no "view source" even when "all" is selected –  webwesen Feb 11 at 17:44
    
Worked for me where the other right-click options didn't –  pelms Apr 29 at 12:03
1  
@N13 You only get the "view source" option on emails that have been sent, not ones you are composing. –  DarkHeart May 23 at 7:13

In 2010 you do the following: (step ONE is very important)

  1. Open the an email...

    ( do NOT try to add the command at the top level of outlook, it will NOT show "view Source")

  2. Right Click the ribbon -> Customize Ribbon

  3. Select All Commands (since you are on an email the "view source will show")

  4. Select "View Source" in and drop it in a new Group.

share|improve this answer
1  
From all the the solutions proposed here, this was the only one that worked for me! Thanks. –  Jpsy Jan 30 at 15:20

I have this issue also. I am sure headers and source were available for most (if not all) messages I received when running Outlook 2007, now it seems to be the exception to the rule.

I have found http://email.about.com/od/outlooktips/qt/How_to_View_the_Complete_Message_Source_in_Outlook.htm that I have only just implemented, so can't say for sure if it will solve the issue for new e-mails.

There is also this interesting article, that while I also haven't been able to verify, might help someone else finding this page. It seems that depending on where you right click in message contents (A method in 2010 to view the source) matters as to whether you get the option to view source, in HTML messages - http://www.outlook-tips.net/tips/view-message-source-outlook/

share|improve this answer
2  
That article explains just how picky the right-click can be, and why seeing a "View Source" depends on where you click. –  N13 Feb 26 '13 at 18:02

Be sure to double click on the message to open it separately and that you are not looking at it in the preview pane. If you single click and the message shows below or to the right of the email list you are in the preview pane. You cannot select view source in the preview pane. Once you have opened it separately, you should be able to select view source. I had this problem and solved by opening the email and not just previewing it.

share|improve this answer

I am using Outlook 2010 for MAC and right clicking (or control clicking) on the email from the inbox list (not the actual email itself) gives me a view source option

share|improve this answer

There is a command view source... in outlook 2010 (office home and business) version 14.0.61.49.

Click the ribbon --> add commands ---> more commands --> all commands --> view source...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.