Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just set up a Debian machine to use as a web server. However, it would randomly lose Internet access for a while, then be fine a few minutes later. Other computers on the same network are fine. I tried a different Ethernet cable, but that's not the problem either. I had Ubuntu on the machine before and the Internet was fine. I can't even SSH the machine on LAN.

What could be the cause? My ISP is Bell Canada and I have DSL.

Edit: Also, I can't access any websites or any devices on LAN from Debian.

share|improve this question
    
Dynamic or static IP? Verified that the no other systems are contending for the same IP? Checked the logs on your web server? –  Tim Brigham Feb 12 '12 at 15:01
    
I'm using DynDNS with a dynamic IP and DHCP for the LAN. The following line is repeated many times in my modem/router's log: DHCPINFORM from 192.168.2.12 (my server is 192.168.2.107). And I forgot to mention that Debian cannot access anything other than localhost. –  Linksku Feb 12 '12 at 15:37
    
I doubt your ISP has anything to do with this if Windows is working fine. That's elementary troubleshooting. What system are you getting your DHCP information from? Do you administer it? –  Magellan Feb 12 '12 at 21:42
    
I getting DHCP info from the modem/router from Bell Canada. I reinstalled Debian, then I lost Internet access again after a while. Before the Internet access broke, I installed UFW, Lynx, and ZIP. –  Linksku Feb 13 '12 at 0:05
add comment

migrated from serverfault.com Feb 14 '12 at 13:49

This question came from our site for professional system and network administrators.

1 Answer

How are you configuring your network? Is it via a tool like network manager or is it directly in /etc/network/interfaces?

It might be possible that one is trying to reconfigure the other periodically.

If you're using it as a server, I would recommend configuring it via /etc/network/interfaces and uninstall/disable network manager or the like.

share|improve this answer
    
Everything is default. Here's my interfaces file: auto lo\n iface lo inet loopback\n allow-hotplus eth0\n iface eth0 inet dhcp –  Linksku Feb 12 '12 at 17:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.