Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an old computer running on P4 processor and ATI Radeon RV100 QY [Radeon 7000/VE] graphics card. Whenever I quit any window manager, the screen goes blank, but it still accepts input i.e. I can run commands on the tty; I just can not see it. This also happens if I change from the WM to any tty's using Alt+Ctrl+Fx keys. What can I do to solve this problem?

EDIT:

I messed around with vesa vga options and none of them produce legible characters upon quitting X or it is displaced to the right. My WM runs at 1280x1024. 0x0324 was the only mode that falls in the latter. A list of modes available:

02: None 00.0: 11001 VESA Framebuffer                           
  [Created at bios.459]
  Unique ID: rdCR.F1E3GTUDf40
  Hardware Class: framebuffer
  Model: "ATI R100"
  Vendor: "ATI Technologies Inc."
  Device: "R100"
  SubVendor: "ATI RADEON VE"
  SubDevice: 
  Revision: "01.00"
  Memory Size: 64 MB
  Memory Range: 0xe0000000-0xe3ffffff (rw)
  Mode 0x0382: 320x200 (+320), 8 bits
  Mode 0x030d: 320x200 (+640), 15 bits
  Mode 0x030e: 320x200 (+640), 16 bits
  Mode 0x030f: 320x200 (+960), 24 bits
  Mode 0x0320: 320x200 (+1280), 24 bits
  Mode 0x0392: 320x240 (+320), 8 bits
  Mode 0x0393: 320x240 (+640), 15 bits
  Mode 0x0394: 320x240 (+640), 16 bits
  Mode 0x0395: 320x240 (+960), 24 bits
  Mode 0x0396: 320x240 (+1280), 24 bits
  Mode 0x03a2: 400x300 (+400), 8 bits
  Mode 0x03a3: 400x300 (+800), 15 bits
  Mode 0x03a4: 400x300 (+800), 16 bits
  Mode 0x03a5: 400x300 (+1200), 24 bits
  Mode 0x03a6: 400x300 (+1600), 24 bits
  Mode 0x03b2: 512x384 (+512), 8 bits
  Mode 0x03b3: 512x384 (+1024), 15 bits
  Mode 0x03b4: 512x384 (+1024), 16 bits
  Mode 0x03b5: 512x384 (+1536), 24 bits
  Mode 0x03b6: 512x384 (+2048), 24 bits
  Mode 0x03c2: 640x350 (+640), 8 bits
  Mode 0x03c3: 640x350 (+1280), 15 bits
  Mode 0x03c4: 640x350 (+1280), 16 bits
  Mode 0x03c5: 640x350 (+1920), 24 bits
  Mode 0x03c6: 640x350 (+2560), 24 bits
  Mode 0x0300: 640x400 (+640), 8 bits
  Mode 0x0383: 640x400 (+1280), 15 bits
  Mode 0x0384: 640x400 (+1280), 16 bits
  Mode 0x0385: 640x400 (+1920), 24 bits
  Mode 0x0386: 640x400 (+2560), 24 bits
  Mode 0x0301: 640x480 (+640), 8 bits
  Mode 0x0310: 640x480 (+1280), 15 bits
  Mode 0x0311: 640x480 (+1280), 16 bits
  Mode 0x0312: 640x480 (+1920), 24 bits
  Mode 0x0321: 640x480 (+2560), 24 bits
  Mode 0x0303: 800x600 (+800), 8 bits
  Mode 0x0313: 800x600 (+1600), 15 bits
  Mode 0x0314: 800x600 (+1600), 16 bits
  Mode 0x0315: 800x600 (+2400), 24 bits
  Mode 0x0322: 800x600 (+3200), 24 bits
  Mode 0x0305: 1024x768 (+1024), 8 bits
  Mode 0x0316: 1024x768 (+2048), 15 bits
  Mode 0x0317: 1024x768 (+2048), 16 bits
  Mode 0x0318: 1024x768 (+3072), 24 bits
  Mode 0x0323: 1024x768 (+4096), 24 bits
  Mode 0x0307: 1280x1024 (+1280), 8 bits
  Mode 0x0319: 1280x1024 (+2560), 15 bits
  Mode 0x031a: 1280x1024 (+2560), 16 bits
  Mode 0x031b: 1280x1024 (+3840), 24 bits
  Mode 0x0324: 1280x1024 (+5120), 24 bits
  Config Status: cfg=new, avail=yes, need=no, active=unknown
share|improve this question

2 Answers 2

You're not saying which X11 version or which distro you are using which is making difficult to help. You should try using a different X11 driver (vesa, ati, vga, ..), and maybe booting with a VESA mode (ie: vga=792 kernel option).

share|improve this answer
    
Sorry, I'm quite a newbie obviously. Do you mean version of xorg? xorg-server 1.11.4 xorg-xinit 1.3.2 xterm 278-1. I didn't install any drivers; at all. I looked for it on Google but didn't find much. What shall I do now? –  Ram Feb 14 '12 at 18:16
    
Looks for info on configuring xorg and try different drivers (vesa, ati, vga, etc) - you may have to create your own xorg.conf and tweak it. But to be honest, if it was me I would just buy a $10 recent graphics card and be done with it. –  totaam Feb 15 '12 at 15:07

I'm having the same kind of problem with a Radeon VE/7000 on a P4 running LMDE 042012, but with Grub graphic mode not always showing. Framebuffer mode works though.

If you are using a flat panel then you can try to alter some BIOS settings recommended by this AMD KB article:

Conflict with USB support from motherboard

In some instances, the graphics card's own BIOS may not initialize correctly due to how USB support is implemented by the system. When this occurs, the card may not be able to correctly support DVI panels, especially under DOS. Please try the following:

  • Disable all USB support in the CMOS SETUP and retest.
  • Disable LEGACY USB support in the BIOS and retest.
  • If you are using a USB keyboard or mouse, please try testing with a PS2 style keyboard and mouse.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.