Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to use a different font and color for the captions on the icons on the desktop. Under Personalize I have been able to change the icon spacing (both horizontal and vertical) and the size of the text. But I cannot change the font nor the color of the displayed text. The font claims to have changed but it doesn't and the color pulldown menu is disabled. I use the non-Aero Windows 7 Basic but I am not able to change the font or the color.

share|improve this question

5 Answers 5

You need a third party tool to customize your desktop icon and for this you can use Iconoid tool. Its freeware and easy to configure now you can do whatever you want with your desktop icon.

share|improve this answer

You can change the font of the text of your desktop icons even when you are not using the Windows 7 Basic theme.

In order to do this, right-click on the desktop and select Personalize. Click Window Color at the bottom of the screen and then Advanced appearance settings... on the next screen. Select Icon from the Item dropdown and pick a font you like (to see it actually changes, pick something out of the ordinary like Comic Sans). When you click the Apply button, the caption under the icons on your desktop should now be rendered in the font you picked.

Window Color And Appearance dialog

Note though, that the color of the icon caption cannot be changed. It will be chosen automatically based on the color of your desktop wallpaper, according to this post on Microsoft Answers:

You cannot change the desktop font color.

Because desktop wallpaper images have varying colors, it is easy for the font colors to be unreadable if they are on top of the same color as a wallpaper image. For instance a black font on top of a dark part of the background image or a white font on a white part of a background image.

The desktop icon fonts are dynamic and will show white on dark backgrounds and change to white with a black shadow effect on a light background.

share|improve this answer

I have discovered that changing the fonts/colors on desktop icons is close to impossible. However I have also discovered that if you personalize (right-click on desktop) and then you select Windows 7 Basic and then change the Windows appearance, and then you select icons on the scroll box and then turn on bold you then end up with a icon caption that is actually readable.

At least I did/can.YMMV.

share|improve this answer

Solved:

I have Windows 7 Ultimate and I followed the post above from PersonalNexus with a slight modification to change the desktop font color (from white to black).

To change your desktop icon font color:

Right click on desktop and select Personalize | click Window Color | Advance Appearance Settings | Select 'Desktop' under Item (not Icon) | change 'Color 1' from Black to White for black desktop icon font color.

And, your desktop font color will change to Black so you can read your icons! If you want white desktop font color just make 'desktop' Item color 1 Black instead of white!

Hope this helps everyone!

share|improve this answer

Finally solved still with the Aero Theme:

  1. Run sysdm.cpl to get to System Properties.
  2. Select Advanced tab and Performance Setting to get to the Performance Options window.
  3. Select "Adjust for best performance" button to clear all the check-boxes.
  4. Use Iconoid to change the icon font color.

If you prefer to still have the peek preview of a window while hovering on the task bar icon, you can select the "Enable desktop composition" and "Use visual styles on windows and buttons" check-boxes.

Have fun!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.