Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Xampp for Windows is installed, and localhost comes up, but if I type localhost/webvilletv.html, which has videos associated with it, the page comes up, but the videos do not play. I get a 403 error for all of the videos in the http response header.

share|improve this question

migrated from serverfault.com Feb 15 '12 at 2:45

This question came from our site for system and network administrators.

2 Answers 2

403 Forbidden

Did you check the permissions of the video files and the folder(s) they're contained in?

share|improve this answer
    
How do I do that? –  Grafica Feb 14 '12 at 22:42
    
The folder containing the videos was "Read Only" in Windows Explorer, so I changed it by unchecking the "Read Only" box and applying the changes, but the videos still don't play. –  Grafica Feb 14 '12 at 23:00
    
What about the files themselves? And what user's permissions are you checking? Does the user that Xampp is running as have permissions to view the folders and files? –  Safado Feb 14 '12 at 23:10
    
The folders for which I unchecked the "Read Only" box keep going back to having the box checked. I need to figure that out. Thanks. –  Grafica Feb 14 '12 at 23:21

In my original question, I was using Windows 7. I attempted to take off the "Read-only" attribute for xampp folder and all subfolders and files by doing the following: unchecking the "Read-only" box in "Properties," but it kept reverting back to being checked; checked "Advanced Security Settings" and all users have full control.

I went into regedit, HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Current Version\Explorer, edited UseSystemForSystemFolders, to 1; went into command line and typed attrib -r +s c:\xampp but I'm still not able to make the "Read-only" change stick.

I went to another computer that is running XP with xampp installed, and the xampp folders keep reverting back to "Read-only" also, but loaded the same html page in the browser with the same videos, and they play. For now, I'm developing my sites on the XP machine.

share|improve this answer
    
Thank GOD for giving me the "real" answer from the Apache Friends forum!!! The folder containing the videos that wouldn't play needed to be decrypted. Now they play with no errors!!! Right-click the folder or file you want to decrypt, and then click Properties. Click the General tab, and then click Advanced. Clear the Encrypt contents to secure data check box, click OK, and then click OK again. –  Grafica Feb 21 '12 at 19:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.